Opened 11 years ago

Closed 11 years ago

#5469 closed defect (fixed)

Selecting grid row causes unexpected scrolling

Reported by: guest Owned by: sorvell
Priority: high Milestone: 1.2
Component: DojoX Grid Version: 1.0
Keywords: scrolling Cc: benschell
Blocked By: Blocking:

Description (last modified by dylan)

Steps to reproduce:

  1. Open e.g. dojox/grid/tests/test_edit.html (also other tests have the problem)
  2. Drag the scrollbar about halfway down
  3. Click on a row somewhere in the middle of the visible area

Bug: The selected row jumps to the top/bottom of visible area, with some flickering.

Environment:

  • FF2, win xp
  • SVN HEAD, currently R11920.

Attachments (2)

index.html (2.1 KB) - added by guest 11 years ago.
grid_test_edit_screenshot.png (68.3 KB) - added by guest 11 years ago.
grid edit example in small screen

Download all attachments as: .zip

Change History (10)

comment:1 Changed 11 years ago by sorvell

(In [12060]) !strict addresses #5469

comment:2 Changed 11 years ago by sorvell

Resolution: fixed
Status: newclosed

Should be addressed by [12060].

When a selection is made, we no longer try to focus the cell in the old selection before focusing the the cell in the new selection. This was causing bogus scrolling.

comment:3 Changed 11 years ago by Adam Peller

Milestone: 1.1

Changed 11 years ago by guest

Attachment: index.html added

comment:4 Changed 11 years ago by guest

Resolution: fixed
Status: closedreopened

I think that this is still a problem in IE, but not in Firefox. I can't reproduce it with the dojox/grid/tests/test_edit.html file that the original reporter used, but I can reproduce it with the file that I attached (index.html).

Open this file in IE and click on any of the cells. The browser will immediately scroll so that the grid is at the top of the browser and the text above (the word "Title") will scroll off. It does not seem to do this in Firefox.

comment:5 Changed 11 years ago by dylan

Description: modified (diff)
Milestone: 1.11.1.1

Changed 11 years ago by guest

grid edit example in small screen

comment:6 Changed 11 years ago by guest

There's more cases where clicking on grid causes unexpected scrolling. The problem can be seen also in grid/tests/test_edit.html It also happens in a grid where one area (cell) is scrollable.

I've seen the problem in IE7 only, Firefox works fine. Using SVN head r13358, win xp.

First resize and scroll test_edit.html as show in grid_test_edit_screenshot.png Now, clicking almost anywhere in grid causes unexpected scrolling.

  • Clicking e.g. "message" column causes the horizontal scrollbar to jump left
  • Clicking in rightmost "status" column causes jump to the right
  • Double clicking in rightmost "amount" or "status" column activates editor, but the scrollbar jumps and the editor is only partially visible.
  • etc

comment:7 Changed 11 years ago by Adam Peller

Cc: benschell added
Priority: normalhigh

comment:8 Changed 11 years ago by Bryan Forbes

Resolution: fixed
Status: reopenedclosed

(In [13793]) refs #6353 !strict

  • Moved dojox.grid.VirtualGrid? to dojox.grid._Grid.
  • Renamed DataGrid?._getItem to DataGrid?.getItem.
  • Added "defaultValue" property to cells and set it to '...'.
  • Added _Grid._fetch() (stub function).
  • Changed _Grid to work with asyncronous stores more efficiently.

refs #6545

  • Changed "itemAttr" on cells to "field".
  • Added "sortDesc" attribute to cells.

fixes #6746, #5469

  • Fixed horizontal scrolling issue in FF2/3.
Note: See TracTickets for help on using tickets.