Opened 12 years ago

Closed 12 years ago

#5461 closed defect (fixed)

dojo.parser and dojox.data.XmlStore

Reported by: criecke Owned by: Jared Jurkiewicz
Priority: high Milestone:
Component: DojoX Data Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

For some reason, the following works fine:

       var ordXml = new dojox.data.XmlStore( {
           url: "datasources/order_combined.xml",         
           rootItem: "order", 
           keyAttribute:"orderNumber", 
           label:"description",
           sendQuery:true
       });            

But the following (with parseOnLoad, etc. turned on) does not:

<div dojoType="dojox.data.XmlStore" 
     url="datasources/order_combined.xml"
     rootItem="order"
     keyAttribute="orderNumber"
     label="description"
     sendQuery="true"
     jsId="ordXml"
></div>

In the declarative case, f you console.dir the args variable inside dojox.data.XmlStore? constructor, it's a null object. Yet, ItemFileReadStore? uses this same setup and works fine in both declarative and programmatic definitions.

-- Craig Riecke (criecke@…)

Attachments (1)

dojox.data.XmlStore_20080102.patch (6.9 KB) - added by Jared Jurkiewicz 12 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by Adam Peller

Component: GeneralDojoX Data
Owner: changed from anonymous to Jared Jurkiewicz

comment:2 Changed 12 years ago by Jared Jurkiewicz

Do you have a testcase for this? I can mock one up, certainly, but it's always faster if I can just pull down a testcase and play with it. :-)

comment:3 Changed 12 years ago by Adam Peller

Reporter: changed from guest to criecke

comment:4 Changed 12 years ago by Jared Jurkiewicz

I see where the issue is. XmlStore? isn't really set up to be constructed declaratively. It uses _* for the values it ends up keying off of.

This can be fixed. Just need to see how pervasive it ends up being.

Fix should just be to change those to public values and allow them to be set declaratively.

comment:5 Changed 12 years ago by Jared Jurkiewicz

I can provide a patch for this. Since I don't have your testcase at hand, can I attach the patch to the tracker and you test it in your environ to verify it works?

Changed 12 years ago by Jared Jurkiewicz

comment:6 Changed 12 years ago by Jared Jurkiewicz

I've added a patch. Can you verify this in your scenario to ensure it works for you? It should, but I would like to be certain before committing it.

comment:7 Changed 12 years ago by Jared Jurkiewicz

Gone ahead and tested the patch against:

IE 6 IE 7 Firefox 2.0.0.11 Safari B3 Opera 9.2 Seamonkey 1.1.2

All the UT passes fine, and my thrown together testcase also seems to pass okay. I'm going to go ahead and check this in, marked fixed. If you, in your testing, determine it isn't fixed, then let me know.

comment:8 Changed 12 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [11941]) Minor update to XmlStore? to make some parameters declaratively settable. fixes #5461 !strict

Note: See TracTickets for help on using tickets.