Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#546 closed enhancement (fixed)

combination effects

Reported by: joe Owned by: Bryan Forbes
Priority: high Milestone:
Component: General Version: 0.2
Keywords: Cc:
Blocked By: Blocking:

Description

dojo needs a combination effect much like scriptaculous... and include demos. and if there is already one, where is the document? if there's a documentation, why is it so hard to find? damn i wanna use dojo, but the documentations stinks.

Change History (6)

comment:1 Changed 13 years ago by anonymous

I agree. I'm working on a research and developement project for my company and I'm playing around with dojo to see if it's something we can use. The problem is, everything I try is pretty much a shot in the dark due to such shoddy documentation. Also, a great deal of the code is nearly impossible to read as it is full of cryptic varible names and horrible code style. From what I've been able to produce so far by "guess-and-check," it seems that dojo may be something we could use. But in it's current state, it would not be economical to do so due to the lack of support.

comment:2 Changed 13 years ago by alex

Owner: changed from anonymous to alex
Priority: highestnormal
severity: majornormal
Status: newassigned

Firstly: it's harder to take bug reports like this seriously when their priority is artifically inflated.

Secondly: The animation system is documented here: http://manual.dojotoolkit.org/animation/Animation.html As you can see, it's not only possible to construct your own "group effects", our system is significantly more flexible than any of the alternatives in this regard.

Lastly: the "dojo.fx" namespace is being rewritten to expose the power of the Animation system in a more coherent way. I will attempt to work your request into the rewrite, however without links to particular APIs that you'd like to see implemented, this is somewhat more difficult. Bug reports should include all data needed by the investigator to solve the issue and this report clearly falls short of the mark.

I will, however, look into it.

Regards

comment:3 Changed 13 years ago by Bryan Forbes

Owner: changed from alex to Bryan Forbes
Status: assignednew

comment:4 Changed 13 years ago by Bryan Forbes

Status: newassigned

comment:5 Changed 13 years ago by Bryan Forbes

Resolution: fixed
Status: assignedclosed

Alex just committed rev 3695 to trunk which adds dojo.lfx (lite effects module). In it, there is dojo.lfx.combine which has the functionality asked for in this bug (besides the documentation stinking).

comment:6 Changed 12 years ago by (none)

Milestone: 0.3release

Milestone 0.3release deleted

Note: See TracTickets for help on using tickets.