Opened 12 years ago

Closed 12 years ago

#5458 closed defect (duplicate)

addRow to empty grid causes error when tabbing to next cell (broken accesibility)

Reported by: guest Owned by: benschell
Priority: high Milestone: 1.1
Component: DojoX Grid Version: 0.9
Keywords: Cc: Becky Gibson, simonjb, brunet@…
Blocked By: Blocking:

Description

Dojo: 1.02 FF (IE?) contact: dave@…

error: this.cell has no properties -- focus.js ln 122

reproduce: run /dojo/dojox/grid/tests/test_mysql_edit.html

1) either just don't worry about the php datasource (we want the grid empty) *or* set it up but change it to return 0 rows

2) click add row

3) the first cell will change to an editor -- enter a number into it and then

4) tab key -- this causes the error, and the next cell's editor does not come up.

Possibly related to this bug? http://trac.dojotoolkit.org/ticket/5430

debugging shows indeed, this.cell is not yet set -- maybe this needs to be set in addRow( or start(

* any other actions (such as clicking on another cell) will prevent this from happing as this.cell get's set. But insertRow->edit first cell -> tab to next cell is a very common thing to do.

Change History (3)

comment:1 Changed 12 years ago by Adam Peller

Cc: Becky Gibson simonjb brunet@… added
Milestone: 1.1

comment:2 Changed 12 years ago by benschell

Owner: changed from sorvell to benschell

I'm taking a stab at a whole bunch of Grid bugs. Re-assigning.

comment:3 Changed 12 years ago by benschell

Resolution: duplicate
Status: newclosed

This is directly related to #5590 and the fix for it fixes this as well. The problem isn't really related to the grid being empty, just that the focus hasn't been set on the grid at the point at which the tab key has been hit. So, attempting to go to the 'next' cell is invalid since no current cell has been selected.

Note: See TracTickets for help on using tickets.