Opened 12 years ago

Closed 11 years ago

#5454 closed task (duplicate)

Check in dndDefault.css

Reported by: ptwobrussell Owned by: nonken
Priority: high Milestone: 1.2
Component: DnD Version: 1.0
Keywords: Cc: ptwobrussell@…
Blocked By: Blocking:

Description

As I've been digging through the awesome (awesome!) Dnd code, I just noticed that dndDefault.css, the stylesheet that accompanies all of the dnd tests isn't checked in under dnd/resources and therefore, all of the nice styling you would expect isn't available unless you manually copy this file or write up your own style.It seems to me that a lot of users would want this style as a reasonable default, or at least have it available in a standard location of the toolkit (esp. if using the CDN), so I was wondering if there was a reason it wasn't already checked in? (And there might be one, but it's just not obvious to me.)

Change History (6)

comment:1 Changed 12 years ago by Adam Peller

Milestone: 1.0.3

comment:2 Changed 12 years ago by Eugene Lazutkin

Milestone: 1.1
Owner: changed from Eugene Lazutkin to dante

Pete --- take a look and find a way to do that.

Currently we do not include any CSS with DnD because it is a part of Dojo Core, and Dojo Core doesn't have any visual definitions. Only Dojo Dijit has it (themes). We need to solve it somehow.

  1. Can we do it for Dojo Core too?
  2. Probably we should include some sane DnD rules in existing themes making sure they don't clash with them.

comment:3 Changed 12 years ago by dante

Status: newassigned

comment:4 Changed 12 years ago by dante

Owner: changed from dante to nonken
Status: assignednew

#6240 is technically a dup of this, though expands on the things needed to be done in more depth.

comment:5 Changed 12 years ago by bill

Milestone: 1.11.2

Move all milestone 1.1 tickets to 1.2, except for reopened tickets and tickets opened after 1.1RC1 was released.

comment:6 Changed 11 years ago by nonken

Resolution: duplicate
Status: newclosed

Duplicate of #6240, I already have put some theme specific classes into dijit, will only close #6240 on confirmation with bill

Note: See TracTickets for help on using tickets.