Opened 12 years ago

Closed 12 years ago

#5449 closed defect (duplicate)

Dojo Chart not rendering Axis legend in the right position

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.1
Component: Charting Version: 1.0
Keywords: Cc: ydewit@…
Blocked By: Blocking:

Description

I am trying to render a chart within one of our pages but the x axis legend is being rendered way down-right.

After some debugging it seems that the legend divs which are absolute positioned dont play well if nested within a relative positioned container (defines a new position context). The top and left positions for the legend divs are calculated using dojo._abs() that afaik calculates based on the document body irrespective of whether there is a relative positioned container element in between.

it seems that instead of calculating the absolute position always to the document body it should be calculated based on the closest relative positioned container or maybe always define the chart element as relative positioned (not sure if this would work).

Change History (3)

comment:1 Changed 12 years ago by Eugene Lazutkin

Milestone: 1.1
Status: newassigned

comment:2 Changed 12 years ago by guest

This is a duplicate of #5168

comment:3 Changed 12 years ago by Eugene Lazutkin

Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.