Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#5448 closed defect (fixed)

toolbar flickers in IE6 when hovering over toolbar buttons

Reported by: liucougar Owned by: nonken
Priority: high Milestone: 1.1
Component: Dijit - Form Version: 1.0
Keywords: Cc: dante, nonken
Blocked By: Blocking:

Description

open dijit ests est_Toolbar.html in IE6, when you hover over toolbar buttons, the whole toolbar expands and the retracts when mouse enters and leaves.

Change History (13)

comment:1 Changed 11 years ago by liucougar

another issue is: the last button in the first toolbar is too tall in IE6

comment:2 Changed 11 years ago by Adam Peller

Cc: dante added
Milestone: 1.1

comment:3 Changed 11 years ago by bill

Seems to only happen when hovering over a depressed toggle button (ex, the "bold" button)

comment:4 Changed 11 years ago by bill

Owner: set to alex

Regression from [11024], see #4816.

comment:5 Changed 11 years ago by bill

PS: presumably due to the margin: -1

comment:6 Changed 11 years ago by Adam Peller

Cc: nonken added

comment:7 Changed 11 years ago by bill

Owner: changed from alex to nonken

Looks like Nikolai fixed this. test_Editor and test_Toolbar are working correctly (albeit loading slowly) on IE6 for me now.

comment:8 Changed 11 years ago by bill

Resolution: fixed
Status: newclosed

comment:9 Changed 11 years ago by bill

Resolution: fixed
Status: closedreopened

Ugh, my mistake... it's not fixed. I forgot that it only occurs when you mouse over a depressed button. Nikolai, can you handle this one? Feel free to roll back [11024].

comment:10 Changed 11 years ago by Adam Peller

actually, it looks like the transparent border to me. Take out the "transparent" in .tundra .dijitToolbar .dijitButtonNode and the problem goes away. Maybe IE6 just doesn't support this, so it throws in a thicker border instead? Maybe this can somehow be conditionalized for ie6?

comment:11 Changed 11 years ago by Adam Peller

nope. that was nonsense. ignore the previous comment

comment:12 Changed 11 years ago by nonken

Resolution: fixed
Status: reopenedclosed

(In [13053]) Rewrote toolbar css, fixes #5448

comment:13 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.