Opened 11 years ago

Closed 11 years ago

#5435 closed defect (fixed)

dijit.TooltipDialog broken after r11841

Reported by: guest Owned by: bill
Priority: high Milestone: 1.1
Component: Dijit Version:
Keywords: dijit.TooltipDialog, dijit.Dialog Cc:
Blocked By: Blocking:

Description

Vladimir Solomenchuk/cla

due to changes in dijit._base.place not orient function in widget call with 3(node, aroundCorner, corner) parameters, instead of 1 (corner)

Index: Dialog.js
===================================================================
--- Dialog.js	(revision 11889)
+++ Dialog.js	(working copy)
@@ -351,14 +351,14 @@
 			this.containerNode.title=this.title;
 		},
 
-		orient: function(/*Object*/ corner){
+		orient: function(node, aroundCorner, /*Object*/ corner){
 			// summary: configure widget to be displayed in given position relative to the button
 			this.domNode.className="dijitTooltipDialog " +" dijitTooltipAB"+(corner.charAt(1)=='L'?"Left":"Right")+" dijitTooltip"+(corner.charAt(0)=='T' ? "Below" : "Above");
 		},
 
 		onOpen: function(/*Object*/ pos){
 			// summary: called when dialog is displayed
-			this.orient(pos.corner);
+			this.orient(null,pos.aroundCorner, pos.corner);
 			this._loadCheck(); // lazy load trigger
 			this.containerNode.focus();
 		},

Change History (7)

comment:1 Changed 11 years ago by Adam Peller

Owner: set to bill

comment:2 Changed 11 years ago by bill

Status: newassigned

Oops, sorry about that, will fix.

comment:3 Changed 11 years ago by bill

PS: but, can you give a more specific description of what problem you are having? All you wrote is that "it's broken". Also, why do you think that Dialog.orient() needs the same signature as dijit._place()'s third argument?

comment:4 Changed 11 years ago by guest

Vladimir Solomenchuk/cla Problem reproduced in test_Toolbar.html. Click Login button and you will receive error "corner.charAt not a function". TooltipDialog?.orient called twice - once from dijit._base.place and second TooltipDialog?.onOpen. Problem caused by call from dijit._base.place at line no 115 with code

if(layoutNode){
   layoutNode(node, choices[i].aroundCorner, corner);
}

comment:5 Changed 11 years ago by bill

Oh I see. OK, thanks!

comment:6 Changed 11 years ago by bill

Ugh, fixed by [11890] but I wrote the wrong version number in the checkin.

comment:7 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.