Opened 11 years ago

Closed 11 years ago

#5423 closed defect (worksforme)

dnd - cross container drop bug - firefox only

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.1
Component: DnD Version: 1.0
Keywords: dnd Cc: mccullor@…
Blocked By: Blocking:

Description

dnd bug (only in firefox) that occurs when dragging & dropping between 2 containers.

Test Subject: http://demo.dev.whmi.biz/js/dijit/dev/subgroups2.html (Firefox Only)

Scenario 1: place your cursor directly on top of any fruit word, then drag it over into the adjacent Vegetables container. you should be able to successfully drop the item.

Scenario 2: place your cursor on any fruit item, but this time be sure to keep your cursor completely off of the word (be sure its still highlighted). Drag it over into the adjacent Vegetables container. you should be unsuccessful in dropping this fruit item into the Vegetables container.

The dnd items can still be managed inside the container with out using the word as a handle; it seems that the problem only exists when traveling between containers.

Change History (4)

comment:1 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.1
Status: newassigned

comment:2 Changed 11 years ago by Eugene Lazutkin

Owner: changed from Eugene Lazutkin to dante
Status: assignednew

Pete --- take a look and find a way to do that.

Currently we do not include any CSS with DnD because it is a part of Dojo Core, and Dojo Core doesn't have any visual definitions. Only Dojo Dijit has it (themes). We need to solve it somehow.

  1. Can we do it for Dojo Core too?
  2. Probably we should include some sane DnD rules in existing themes making sure they don't clash with them.

comment:3 Changed 11 years ago by Eugene Lazutkin

Owner: changed from dante to Eugene Lazutkin
Status: newassigned

Hmm, wrong ticket, sorry.

comment:4 Changed 11 years ago by Eugene Lazutkin

Resolution: worksforme
Status: assignedclosed

The link to the test case went dark, there is no attachment demonstrating the problem, I cannot reproduce it with standard tests (e.g., test_dnd.html works fine in both scenarios). Closing for now.

Note: See TracTickets for help on using tickets.