Opened 11 years ago

Closed 11 years ago

#5416 closed defect (invalid)

Grid content doesn't render when store items contain objects

Reported by: guest Owned by: sorvell
Priority: high Milestone: 1.2
Component: DojoX Grid Version: 1.0
Keywords: Cc: juho.manninen@…
Blocked By: Blocking:

Description (last modified by Bryan Forbes)

Grid content doesn't render when ItemFileReadStore? input data contains objects inside items, e.g.:

items: [
  { name:'Africa', type:'continent', breaker: {} }
]

To reproduce this just add the breaker from above to the countries.json on test page: Grid using Dojo.Data.

This has been discussed at the forums: Getting grid to work with dojo.data and in the issue: dojo.data.ItemFileReadStore breaks when items contain objects

Change History (2)

comment:1 Changed 11 years ago by dylan

Milestone: 1.0.31.2

comment:2 Changed 11 years ago by Bryan Forbes

Description: modified (diff)
Resolution: invalid
Status: newclosed

This is related to #5396 and the grid isn't displaying data because there is no type map. Marking invalid.

Note: See TracTickets for help on using tickets.