Opened 11 years ago

Closed 11 years ago

#5401 closed defect (duplicate)

loading problem with jsessionId

Reported by: guest Owned by: James Burke
Priority: high Milestone:
Component: General Version: 0.9
Keywords: dijit url Cc:
Blocked By: Blocking:

Description

I was using the JSTL library for generating correct url. The c:url tag just generates the correct url when given a relative path. I was using <script src="<c:url value="/ajax/dojo/dojo.js"/>" djConfig="parseOnLoad:true"> </script> I can see a lot of 404 for my dijit resources when I do a dojo.require on them. The firebug told GET http://localhost:8080/ajax/dojo/../dijit/TitlePane.js 404(10ms) This occurs the first time when I hit the page from a fresh IE or FF. I am using JBoss as the webserver. If I refresh the same page once again all 404 errors are gone, and all my widgets are loading. All I noted is that there is a ;jsessionid=FSDSDK23232eSDSDS is getting appended to the url initially , but once a session is created and page refreshed that parameter is not in url. The problem is if this gets appended I get a 404 otherwise no.

Some Regexp match problem I believe.?

Change History (3)

comment:2 Changed 11 years ago by bill

Owner: changed from anonymous to James Burke
Summary: dijit - url problemloading problem with jsessionId

Actually, the only thing that matters is what page gets sent down to the browser. It doesn't matter whether it was generated with JSTL, JBoss, etc. Where is session ID getting added? Do you mean that the page sent to the browser contains something like

<script src="/ajax/dojo/dojo.js?jsessionid=FSDSDK23232eSDSDS" djConfig="parseOnLoad:true"> </script>

or that you see a

GET http://localhost:8080/ajax/dojo/../dijit/TitlePane.js?jsessionid=FSDSDK23232eSDSDS

in firebug?

comment:3 Changed 11 years ago by James Burke

Resolution: duplicate
Status: newclosed

Closing as a dupe of #5732, which is fixed in 1.1

Note: See TracTickets for help on using tickets.