Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#5345 closed defect (invalid)

dojo.query fails on label[for='oc5']

Reported by: bill Owned by: alex
Priority: high Milestone: 1.1
Component: Query Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

Load test_validate.html in firefox and then in the console try

dojo.query("input[id='oc5']");

(which works), but then try

dojo.query("label[for='oc5']");

which doesn't.

Change History (7)

comment:1 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [11890]) Fix exception positioning tooltip dialog, regression in [11841]. Refs #5214, fixes #5345.

comment:2 Changed 12 years ago by bill

Resolution: fixed
Status: closedreopened

Above checkin had wrong bug# listed. It fixed #5435, not this bug.

comment:3 Changed 12 years ago by dylan

Milestone: 1.2
Summary: dojo.query fails on label[for='oc5'] (FF)dojo.query fails on label[for='oc5']

This is confirmed in Max OS X Firefox 2, Firefox 3 Beta 3, and Safari 3.

comment:4 Changed 12 years ago by alex

Status: reopenednew

comment:5 Changed 12 years ago by alex

Status: newassigned

comment:6 Changed 12 years ago by alex

Milestone: 1.21.1
Resolution: invalid
Status: assignedclosed

looking at test_validate.html, the result seems to be right. There's no label element with a for value of "oc5" in the page. Searching instead for:

dojo.query("label[for='q05']");

yeilds a single value (as expected). Marking invalid.

comment:7 Changed 10 years ago by bill

Component: CoreQuery
Note: See TracTickets for help on using tickets.