Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#5337 closed defect (fixed)

NumberSpinner: "no inherited onfocus method" error

Reported by: bill Owned by: Adam Peller
Priority: high Milestone: 1.1
Component: Dijit - Form Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

When focusing on the first spinner in test_Spinner.html, get "no inherited focus method" error in console.

It's from NumberTextBoxMixin::onfocus, which calls this.inherited(arguments) (even though there is no onfocus function in an inherited class, at least in this case). It's a regression from [11716].

Change History (3)

comment:1 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [11788]) Removing inherited call for onfocus, since there typically is none. Fixes #5337.

comment:2 Changed 12 years ago by Adam Peller

(In [11791]) Make the custom example bidi-compliant. Refs #5337.

comment:3 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.