Opened 12 years ago

Closed 12 years ago

#5335 closed defect (fixed)

Can't overshoot on an easing function.

Reported by: Bryan Forbes Owned by: Bryan Forbes
Priority: high Milestone: 1.1
Component: fx Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Line 239 in _base/fx.js looks like this:

			if(step < 1){

The problem is that with the code the way it is, you cannot do an overshoot with an easing function. We should really be checking the animation's _percent property instead, since that will always be between 0 and 1.

Change History (1)

comment:1 Changed 12 years ago by Bryan Forbes

Resolution: fixed
Status: newclosed

(In [11753]) fixes #5335.

  • Changed _Animation to check the _percent property rather than the step in the _cycle function to allow overshooting in an easing function.
Note: See TracTickets for help on using tickets.