Opened 12 years ago

Closed 12 years ago

#5295 closed defect (fixed)

dojo.coords: ComboBox popup problem in themetester.html (Safari)

Reported by: Douglas Hays Owned by: sjmiles
Priority: high Milestone: 1.1
Component: Core Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

Run dijit/themes/themeTester.html using safari3.0.3/Win, select Form Feel, and scroll down to the ComboBox? section. Click the arrow and the popup renders and then closes. This works well with FF2 and IE6.

Attachments (1)

coordsbug.html (868 bytes) - added by Douglas Hays 12 years ago.
works on ie7, ff2, and opera9, fails on safari3

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by haysmark

Can't reproduce in [11677].

comment:2 Changed 12 years ago by Douglas Hays

Seems to happen when you click on the left padding area of the box.

comment:3 Changed 12 years ago by haysmark

Ok now I see it.

comment:4 Changed 12 years ago by Douglas Hays

Component: DijitCore
Owner: changed from haysmark to sjmiles
severity: normalmajor
Summary: ComboBox popup in themetester.html closes instantly on safaridojo.coords: ComboBox popup problem in themetester.html

The problem is dojo.coords. On safari it is returning the wrong value for the combobox in themetester.html. I'll attach a tiny html file to demonstrate the problem.

Changed 12 years ago by Douglas Hays

Attachment: coordsbug.html added

works on ie7, ff2, and opera9, fails on safari3

comment:5 Changed 12 years ago by bill

Summary: dojo.coords: ComboBox popup problem in themetester.htmldojo.coords: ComboBox popup problem in themetester.html (Safari)

comment:6 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [12117]) Modify API doc of dojo._abs() to match behavior on FF. Modify behavior of dojo_abs() on Safari3 and Opera9 to match behavior on FF. This fixes popup positioning on safari (fixes #5295). html.js unit test still passes. Tested on FF2, FF3, Safari, IE6. !strict

Note: See TracTickets for help on using tickets.