Opened 14 years ago

Closed 13 years ago

#529 closed defect (worksforme)

wrong node for dojo.dom.getAncestors(node, null, true)

Reported by: zet4080@… Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.2
Keywords: Cc:
Blocked By: Blocking:

Description

Hi!

If I use

parent = dojo.dom.getAncestors(node, null, true);

I don't get the parent node as expected but the node itself. Is this for purpose or is it an error?

Regards, Jochen Zimmermann

Change History (1)

comment:1 Changed 13 years ago by Tom Trenka

Resolution: worksforme
Status: newclosed

This is by design; the first node passed back in the array of nodes will always be the node passed.

Note: See TracTickets for help on using tickets.