Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#5287 closed defect (invalid)

Bluring from FilteringSelect not trigger required condition

Reported by: guest Owned by:
Priority: low Milestone:
Component: Dijit - Form Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

If you set a FilteringSelect? field (and probably ComboBox?) to required:true it doesn't always behave as it should. The following steps will result in the field not highlighting when the field is empty.

  1. Select/Enter? some text
  2. Erase the text (the popup will appear)
  3. Blur away (click off the field)
  4. Field will not highlight as it should

Note: If you now click on the field and blur off it will highlight. The problem is related to the fact that the contents were just erased and doing so caused the popup to appear. (autocomplete is on)

Change History (3)

comment:1 in reply to:  description Changed 12 years ago by guest

This bug should be closed. The error was caused by an exception that occurred in my code in my onChange function which was attempting to look for an empty string in the store because .getValue() returns "" when nothing is selected.

comment:2 Changed 12 years ago by Adam Peller

Milestone: 1.0.2
Resolution: invalid
Status: newclosed

comment:3 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.