Opened 14 years ago

Closed 14 years ago

#528 closed defect (duplicate)

back/forward io.bind() browser history?

Reported by: jkuhnert@… Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

I feel bad for posting bugs now, feel like I should know how to fix it myself but this seems like such an overarching thing...

is http://archive.dojotoolkit.org/nightly/tests/io/test_BrowserIO.html supposed to be working in FF?

If I go to the url in question and hit the back button no alerts pop up, but hitting forward after that does cause an alert. Subsequent back/forward hits always cause the forward alert to show up but never the back.

Change History (1)

comment:1 Changed 14 years ago by James Burke

Resolution: duplicate
Status: newclosed

I believe this is a duplicate of the ticket #517. In general, there is not a way to set up a back button handler for the first page that loads. When you press Back, it goes essentially to the original page (does not have a handler). When you press Forward, you trigger the handler that was registered when the dojo.io.bind() request happened.

I'm not sure if I broke this when I did the back/forward refactoring to dojo.undo.browser or if back/forward handling was not ever working for when you go back to the first page. I am going to try to fix it in any case, but I'll track it in bug #517. Closing this bug as a duplicate of #517.

Note: See TracTickets for help on using tickets.