Opened 12 years ago

Closed 11 years ago

#5263 closed defect (fixed)

RTL Grid problems with column resizing

Reported by: Adam Peller Owned by: benschell
Priority: high Milestone: 1.1
Component: DojoX Grid Version: 0.9
Keywords: bidi Cc: hwcdl@…
Blocked By: Blocking:

Description (last modified by Adam Peller)

Dragging the columns around in the test example in rtl leads to trouble. In IE7, the column header will move around when resized, and then the column header is not aligned with column body. Evan provided a video to illustrate the problem:

http://dojotoolkit.org/~peller/grid-bidi-error-ie7-1.swf

Attachments (2)

5263.patch (9.1 KB) - added by benschell 11 years ago.
New patch, as described below.
5263.2.patch (9.1 KB) - added by Jared Jurkiewicz 11 years ago.
Minor update to Ben's patch. Removed commented out stuff.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Adam Peller

Description: modified (diff)

comment:2 Changed 11 years ago by benschell

Owner: changed from sorvell to benschell

I'm taking a stab at a whole bunch of Grid bugs. Re-assigning.

comment:3 Changed 11 years ago by benschell

Status: newassigned

This is partly a bug, partly an issue with the test page.

The page that was used to test with does not have the appropriate stylesheets loaded for Grid RTL support. I've attached a patch with a new test page with the appropriate stylesheets loaded. Using the same test page, I saw the same screwy behavior (columns not lining up correctly, the wrong column resizing, etc.) but all seems to be ok with the new test page (other than what's outlined below).

However, with the new test page, the same behavior occurs only when the widths of the columns is less than the width of the overall Grid. The issue is that the header is floated to the left, while the contents in the table are oriented to the right as expected. The offending rules are in Grid_rtl.css. The float of the content had no effect at this point, and attempting to float the content through a more relevant rule does not work correctly, given the "page"'s extreme width. The patch above deletes Grid_rtl.css, as the first rule is the cause of this bug, the second corrects the first rule on IE, and the third rule was in-applicable.

The patch also includes a fix to the most generic test page, test_grid.html, in order to bring in relevant CSS files.

comment:4 Changed 11 years ago by benschell

Please disregard previous patch/post, issues still exist.

comment:5 Changed 11 years ago by benschell

New patch attached. Now, the appropriate column is resized and the header is automatically slid into the correct location. However, an issue persists, which is filed as ticket #5978. Also, testing this issue also brings up #5977.

Same updates to test_grid.html to bring in relevant CSS files.

Changed 11 years ago by benschell

Attachment: 5263.patch added

New patch, as described below.

Changed 11 years ago by Jared Jurkiewicz

Attachment: 5263.2.patch added

Minor update to Ben's patch. Removed commented out stuff.

comment:6 Changed 11 years ago by Jared Jurkiewicz

Resolution: fixed
Status: assignedclosed

(In [12740]) Fix for RTL issue supplied by Ben Schell. fixes #5263 !strict

Note: See TracTickets for help on using tickets.