Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#5251 closed enhancement (worksforme)

ComboBox/FilteringSelect flicker w/drop down width

Reported by: guest Owned by:
Priority: low Milestone: 1.1
Component: Dijit - Form Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

I've noticed a rendering glitch with the FilteringSelect/ComboBox? popup.

When the arrow is clicked the entire menu will appear without a scrollbar for a split second with a width equal to the longest string in the list. Then the element width will be adjusted to the width of the widget and gain a scrollbar. Depending on where the view port is scrolled the popup may also reposition itself above the widget and change its height. This can be seen in the Dojo ComboBox? example under dijit/tests/form and also in the FilteringSelect? examples.

I'm using Firefox 2.0.0.10 on Linux

Change History (6)

comment:1 in reply to:  description Changed 11 years ago by guest

This is a duplicate of #5042 and #5039. I apologize for not searching for existing bugs before posting.

comment:2 Changed 11 years ago by bill

Milestone: 1.12.0
Summary: ComboBox/FilteringSelect Rendering GlitchesComboBox/FilteringSelect flicker w/drop down width

Hmm, I don't think it is a duplicate. #5039 is about the width of the combobox itself, not about the width of the dropdown, right?

comment:3 Changed 11 years ago by Douglas Hays

Milestone: 2.01.1
Resolution: fixed
Status: newclosed

I don't see this in the current 1.1 trunk. Please recheck with the latest to verify.

comment:4 Changed 11 years ago by Adam Peller

Resolution: fixed
Status: closedreopened

comment:5 Changed 11 years ago by Adam Peller

Resolution: worksforme
Status: reopenedclosed

comment:6 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.