Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#5214 closed enhancement (fixed)

Tooltip/ValidationTextBox error message: allow to specify position

Reported by: bill Owned by: bill
Priority: high Milestone: 1.1
Component: Dijit - Form Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Many people have requested the ability to be able to control positioning of a tooltip / validation error message.

Think about doing this for 1.1.

Issues include:

  • tooltip position should change from left to right depending on BIDI (right in western countries but left with hebrew or arabic scripts)
  • tooltip position must change from bottom to top if there isn't enough room on the bottom
  • a tooltip on the bottom (the natural position) is good in general but interferes with the drop down from a DateTextBox, FilteringSelect, DropDownButton. In that case would like to put the tooltip above and the drop down below, but that won't work if the control is positioned at the top of the viewport (possibly because the user scrolled the viewport)
  • a Tooltip can be attached to multiple nodes, and perhaps you would want each node to have different positioning of the tooltip?

Change History (6)

comment:1 Changed 12 years ago by bill

Description: modified (diff)

comment:2 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [11817]) User defined tooltip positioning. Still needs more testing but basics are working. Tooltip positioning is specified via dijit.Tooltip.defaultPosition, and can be overrode on a per-tooltip basis by "position" parameter (or "tooltipPosition" on *TextBox? widgets). Fixes #5214.

comment:3 Changed 12 years ago by bill

(In [11841]) Fix tooltip positioning the first time an "above" tooltip is shown. Refs #5214, #5406.

comment:4 Changed 12 years ago by bill

(In [11890]) Fix exception positioning tooltip dialog, regression in [11841]. Refs #5214, fixes #5345.

comment:5 Changed 12 years ago by bill

(In [11893]) Intermediate checkin to fix positioning of above/below tooltips positioned on right hand side of viewport. Aligns tooltip right-hand-side with target right-hand-side, and puts arrow near right. Also fixed rhino warnings in Button.js. Refs #5214.

comment:6 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.