Opened 12 years ago

Closed 12 years ago

#5202 closed defect (fixed)

dialogs have wrong "esc" behavior when popup for form field has sub-popup

Reported by: alex Owned by: Douglas Hays
Priority: high Milestone: 1.1
Component: Dijit Version: 1.0
Keywords: keyboard, a11y, dijit Cc: alex
Blocked By: Blocking:

Description

to reproduce, go to:

dijit/tests/test_Dialog.html

open the first dialog, tab into the third item (which should open the popup dialog). Hit "esc". Note that the popup isn't dismissed, instead the entire dialog is. This is not the expected behavior.

The behavior is much worse if you tab to the next input field which has a time picker. Since the time picker popup is often in the wrong place and does not have keyboard hinting for selecting the correct time, it is natural to want to dismiss it (since it's useless to keyboard users). This forces the reflexive "esc", thereby potentially destroying work in the dialog. This is highly sub-optimal.

Change History (3)

comment:1 Changed 12 years ago by bill

I'm not seeing that behavior at all. Hitting ESC on a DateTextBox? or TimeTextBox? seems to have no effect (even if you hit it twice). What browser are you using?

comment:2 Changed 12 years ago by Douglas Hays

Owner: changed from bill to Douglas Hays

comment:3 Changed 12 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [12352]) Fixes #5202 !strict. Add keyhandler in _DateTimeTextBox.js to trap ESCAPE key.

Note: See TracTickets for help on using tickets.