Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5188 closed defect (duplicate)

Accordion container fails to load properly when initially hidden

Reported by: guest Owned by:
Priority: high Milestone:
Component: Dijit Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

If an accordion container is placed in a div which is initially hidden (i.e., display: none), the widget fails to load properly. I have a small test case at http://queens.db.toronto.edu/~nilesh/misc/dojo/accordion-widget/ which shows this bug. The test page puts the widget in a div which is initially not hidden, and clicking on the link displays it.

I have tested it on Firefox 2.0 on Linux. This looks like a bug to me.

Change History (4)

comment:1 Changed 12 years ago by bill

Resolution: duplicate
Status: newclosed
Summary: Accordion container failes to load properly when initially hiddenAccordion container fails to load properly when initially hidden

Right, this is a duplicate of #4169. It's a design limitation of the current system.

comment:2 Changed 12 years ago by bill

PS: I am curious though just what you are doing. I wonder if you really need a standard AccordionContainer? that's hidden, or maybe something similar, like a div full of TitlePanes?, or maybe you want an Accordion but without the javascript sizing (the part about calculating the height of the visible content == height of the accordion - height of all the title bars). I ask because the javascript sizing doesn't mesh well with things that are hidden.

comment:3 Changed 12 years ago by guest

@bill I am trying to build a sidebar, which is initially hidden. The accordion container is to reside inside the sidebar. One workaround is to make the sidebar initial open, and close after everything loads, but that looks really ugly. I hope this issue is fixed soon.

comment:4 Changed 12 years ago by bill

Patches are welcome. Or as a workaround I think you can just call resize() on the AccordionContainer? after you show it.

Note: See TracTickets for help on using tickets.