Opened 12 years ago

Closed 12 years ago

#5186 closed defect (invalid)

Gallery error in IE

Reported by: guest Owned by: sos
Priority: high Milestone:
Component: Dojox Version: 1.0
Keywords: Gallery Cc:
Blocked By: Blocking:

Description

I have a file using the gallery which crashes when using IE in Slide Show.js This works in Firefox

I also noticed that on Opera the thumbnails are tiny and the large picture is not shown.

IE error is here.....

var onEnd = function(a,b,c) {

var img = _this.images[idx].firstChild; if(img.tagName.toLowerCase() != "img"){img = img.firstChild;}

CRASH HERE------> title = img.getAttribute("title");

The page is avalailable with all css images etc at http://www.polysteelband.co.uk/newpolysteel/galtest/newgallery.shtml

This is running with 1.0.0rc1.

The json, images and css are essentially the ones from the test folder with paths etc changed for my server.

Steve

Change History (4)

comment:1 Changed 12 years ago by Adam Peller

Component: GeneralDojox
Milestone: 1.1
Owner: changed from anonymous to Tom Trenka

comment:2 Changed 12 years ago by Tom Trenka

Owner: changed from Tom Trenka to dante

comment:3 Changed 12 years ago by dante

Milestone: 1.1
Owner: changed from dante to sos

comment:4 Changed 12 years ago by sos

Resolution: invalid
Status: newclosed

It turns out that this is not a bug in the dojo code. The user has set an identical ID on another DOM element, which caused a conflict. Changing the id of the users element fixes this issue.

Note: See TracTickets for help on using tickets.