Opened 12 years ago

Closed 11 years ago

#5162 closed defect (wontfix)

doStartEdit functionality must return a return value from canEdit or cell stays in editor mode

Reported by: guest Owned by: sorvell
Priority: high Milestone: 1.1
Component: DojoX Grid Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

When using doStartEdit functionality of grid if you do not return a this.canEdit(inFieldIndex, inRowIndex) value then it will leave the cell in editor mode and you cannot escape out of the cell to cancel the edit.

Change History (4)

comment:1 Changed 12 years ago by Adam Peller

is this critical enough for 1.0.1?

comment:2 in reply to:  1 Changed 12 years ago by guest

Replying to peller:

is this critical enough for 1.0.1?

Personally, this is not crucial for my uses because after reading the doStartEdit function in dojox.grid I was able to figure out that it expected me to return a value. I am figuring that the general use of this function will be to store the current value so that if a user edits the cell, hits the enter key, but does not change a value that it will not be submitted to a database (which I imagine many users do when a cell is finished being edited). Without this function working correctly, in conjunction with not knowing enough about dojo to read the source and figure out that you need to return a value in your personal function, some users may be turned off that their data is being submitted with every save of the cell even if the value did not change.

comment:3 Changed 12 years ago by Adam Peller

Milestone: 1.0.11.1

comment:4 Changed 11 years ago by sorvell

Resolution: wontfix
Status: newclosed

Cannot reproduce the problem in the bug. The return value of grid.doStartEdit is not used at all so removing the return from doStartEdit in [12838].

Note: See TracTickets for help on using tickets.