Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#5141 closed defect (duplicate)

Dialog hide() and then uninitialize() produces js error

Reported by: guest Owned by:
Priority: high Milestone: 1.0.1
Component: Dijit Version: 1.0
Keywords: Dialog hide initialize Cc: tk
Blocked By: Blocking:

Description

If you create a dialog, and then hide it, and uninitialize it, it produces an error: this.domNode has no properties. I use this when creating dialogs dynamically, and I have to uninitialize them in order to be able to create and show them again.

BTW, just unitializing without hiding it will destroy the widget without error, but it will leave the widget showing.

I'm using FF 2.0.0.8 on a Mac, against dojo 1.0.0

Attachments (1)

dialog_test.html (1.2 KB) - added by guest 12 years ago.
Dialog test case - popup dialog and then hit "ok" to hide() and initialize()

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by guest

Attachment: dialog_test.html added

Dialog test case - popup dialog and then hit "ok" to hide() and initialize()

comment:1 Changed 12 years ago by bill

Looks like #5118 but I guess subtly different.

comment:2 Changed 12 years ago by tk

Cc: tk added

Same as #5118 I would say... the problem is, you have to allow time for the underlay widget to tear down... otherwise dlg.destroy() happens before the underlay's does and its domNode dissapears and you get the this.domNode error...

comment:3 Changed 12 years ago by bill

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.