Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#5140 closed defect (wontfix)

Some TextBox problems

Reported by: guest Owned by: bill
Priority: high Milestone: 1.1
Component: Dijit - Form Version: 1.0
Keywords: textBox Cc:
Blocked By: Blocking:

Description

Hi,

I've some problems with the TextBox?.
1) In firefox (rv:1.8.1.9) when you move the mouse over a TextBox?, I've a 'Permission denied to get property HTMLDivElement.parentNode' and it seems to be the same for all widgets using a textbox

2) Type a value in the TextBox? (onChange tiggered) then change the value using the setValue function and type the first value again in the textbox. The onChange isn't tiggered.

3) When you have 2 textbox. The first textbox showing an alert in the onChange. Type a value in the first textBox, press tab. The alert is show. When the alert is closed, the focus change to the second textbox. Nice but when you type a value in the second textBox and leave it, the onChange isn't triggered. You must click in the second textbox and only after that the onChange is tiggered.

       	<script type="text/javascript" djConfig="parseOnLoad: true,debug:true" src="./dojo/dojo.js.uncompressed.js"></script>
        <script type="text/javascript">
        dojo.require("dojo.parser");
	    dojo.require("dijit.form.TextBox");
        dojo.require("dijit.form.Button");

		function test()
		{
			dijit.byId("txt_test").setValue("z");
		}
		function change()
		{
			alert('change');
		}
     </script>
     
</head>
<body class="tundra">
	<input id="txt_test" type="text" dojoType="dijit.form.TextBox" onChange="change"/>
	<input id="txt_test2" type="text" dojoType="dijit.form.TextBox" onChange="change"/>
	<input type="button" label="click to change value in first TextBox" dojoType="dijit.form.Button" onClick="test"/> 
</body>

Change History (6)

comment:1 Changed 12 years ago by bill

Component: GeneralDijit
Milestone: 1.0.1
Owner: changed from anonymous to Douglas Hays

Not sure how serious these issues are but marking as 1.0.1 for now. (Also never heard of firefox "1.8.1.9". There's just version 1.5 (no longer supported), and 2.0 (the current version), and 3.0 (the next version))

comment:2 Changed 12 years ago by Douglas Hays

so gecko 1.8.1.9 = FF 2.0.0.9 I can't recreate problem #1 using the testcase given (FF 2.0.0.9 on WinXP). If possible, please provide a URL having the problem. Problem #2 is already fixed in 1.0.1 (1.0 branch). Problem #3 has been recreated and will be fixed under this ticket.

comment:3 Changed 12 years ago by Douglas Hays

Owner: changed from Douglas Hays to bill

Problem #3 seems to be a problem with the focus manager. When you tab from input#1 (that has been changed) to input #2, the browser moves focus to input#2, _onBlur#1 fires, onChange#1 fires, onchange handler calls alert which causes _onBlur#2 to fire, alert box is closed by the user, focus resumes to input#2 by the browser, type something, tab to the button, the focus manager will not call _onBlur#2 again.

I can workaround this problem by calling this.focus inside the onkeyup in textbox but this problem could manifest itself with all other widgets and may need a more robust solution.

comment:4 Changed 12 years ago by bill

Milestone: 1.0.11.1

OK, it is sort-of a problem with the focus manager (like you said), but it's caused by a FF2 bug which is fixed in FF3. It works fine in IE6 and Safari3 already. So I'm tempted to say that we won't fix issue #3.

The bug is that there's an onblur event (of the <input>) when the alert pops up, but no corresponding onfocus event when the alert is closed.

comment:5 Changed 12 years ago by bill

Resolution: wontfix
Status: newclosed

comment:6 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.