Opened 12 years ago

Closed 11 years ago

#5124 closed defect (fixed)

ComboButton, FF2 only: no focus box

Reported by: ptbrunet Owned by: Becky Gibson
Priority: high Milestone: 1.2
Component: Dijit - LnF Version: 0.9
Keywords: a11y Cc: brunet@…
Blocked By: Blocking:

Description (last modified by davidb)

Go to the button test and move focus to a combo button. There is no focus box for either part of the button.

Fails in FF2.

FF3, IE6/7 are OK.

Change History (7)

comment:1 Changed 12 years ago by Becky Gibson

This is a duplicate that I'll need to go search for. This is a FF2 issue and is fixed in FF3. It seems that FF2 does not draw the focus border on table cells.

comment:2 Changed 12 years ago by Douglas Hays

Owner: set to Becky Gibson

comment:3 Changed 12 years ago by Becky Gibson

Milestone: 1.11.2

comment:4 Changed 12 years ago by davidb

Description: modified (diff)

I can't recreate this in FF2 (OSX) I tried all the buttons on: http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_Button.html

comment:5 Changed 11 years ago by Becky Gibson

Component: DijitDijit - LnF
Keywords: a11y added

There is some focus indication on FF2 in windows but it is not quite right - only around part of the combo part with focus. Moving to dijit-LnF for a second opinion on the priority of this.

comment:6 Changed 11 years ago by Becky Gibson

Status: newassigned

comment:7 Changed 11 years ago by Becky Gibson

Resolution: fixed
Status: assignedclosed

(In [14382]) fixes #5124. related to #4748. Modified button.css to make the combobutton focus border transparent so FF2 focus rectangle is visible. Still not great but focus is visible and better than the partial focus rectangle that was being displayed before. With this change I had to add a dijit_a11y class for the combobutton in ff_2. Also fixed a space typo in toolbar.css for ff_2 combobutton.

Note: See TracTickets for help on using tickets.