Opened 12 years ago

Closed 12 years ago

#5112 closed defect (fixed)

Lightbox: Safari fails every 2nd time

Reported by: guest Owned by: dante
Priority: high Milestone: 1.1
Component: Dojox Version: 1.0
Keywords: dojox.image.Lightbox, Safari Cc:
Blocked By: Blocking:

Description

Like IE in Ticket #4868, Safari also fails to open an image every 2nd time. If I open another image (e.g. image A -> image B -> image A), there is no problem. The problem is only: image A -> image A.

Change History (3)

comment:1 Changed 12 years ago by dante

Milestone: 1.0.11.1
Owner: changed from Tom Trenka to dante
Status: newassigned

mmm, more image onLoad love. i'll look into it. safari 2? safari 3? windows? mac? thanks.

comment:2 Changed 12 years ago by guest

Safari 3.0.4 (the standard-version of Leopard)

comment:3 Changed 12 years ago by dante

Resolution: fixed
Status: assignedclosed

(In [11521]) fixes #5112 - turns out if you don't change the .src on an image in safari (to a different url) the onLoad trigger is never reset / refired. setting the dialog to blank.gif on hide() fixes this.

Note: See TracTickets for help on using tickets.