Opened 12 years ago

Closed 12 years ago

#5075 closed defect (wontfix)

Lightbox: underlay doesn't work properly

Reported by: guest Owned by: Tom Trenka
Priority: high Milestone: 1.1
Component: Dojox Version: 1.0
Keywords: dojox.image.Lightbox Cc:
Blocked By: Blocking:

Description

The class .dijitDialogUnderlay isn't set correctly for the intended use.

Change History (2)

comment:1 in reply to:  description Changed 12 years ago by guest

The class .dijitDialogUnderlay should e.g. be:

.dijitDialogUnderlay {

/* basic */ background-color:#333; position: fixed; top: 0; left: 0; /* special */ filter: alpha(opacity=60); -moz-opacity: 0.60;

}

Greez Simon

comment:2 Changed 12 years ago by dante

Milestone: 1.0.11.1
Resolution: wontfix
Status: newclosed

not sure the issue here. the .dijitDialogUnderlay defined in Lightbox.css is simply meant to override the default color of #fff for the underlay and change to #000, leaving the basic dijit underlay otherwise untouched. when you say "not used as intended" I am inclined to agree, but not for the above stated reasons. what i'm doing "wrong" is changing the default underlay color for any dialogs on the same page as lightbox, which is the only current way to do so. underlay is a child of body, and a sibling of the lightbox dialog, so without adding a param to config the color of the underlay in js, i have to clobber the definition via lightbox.css ... even if a class like .dijitDialogUnderlay > .dojoxLightBox { ... } would work, it would still affect all dialogs with underlays.

Note: See TracTickets for help on using tickets.