Opened 12 years ago

Closed 10 years ago

Last modified 4 years ago

#5074 closed enhancement (fixed)

Non gregorian calendars support

Reported by: guest Owned by: Adam Peller
Priority: high Milestone: 1.4
Component: Dojox Version: 1.0
Keywords: Cc: hossamt@…, hhelena@…
Blocked By: Blocking:

Description (last modified by Adam Peller)

Hi

non gregorian calendars needs to be supported such as Islamic(Hijri) calandar and Hebrew Calendars

Attachments (2)

dijit5074.patch (10.2 KB) - added by Adam Peller 10 years ago.
Initial patch to Dijit to support 'datePackage' by Helena Halperin (IBM-IL, CCLA). Needs further review.
hebrew5074.patch (77.3 KB) - added by Adam Peller 10 years ago.
dojox.date.hebrew refactor by Helena Halperin (IBM-IL, CCLA) to support 'datePackage' in Dijit. Needs further review.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 12 years ago by Adam Peller

Component: DateDojox
Milestone: 1.1
Owner: changed from Adam Peller to Tom Trenka

While this is a great feature, it's not in the plans for 1.1. It might make a good dojox project if someone is able to take it on or contributes the code.

comment:2 Changed 12 years ago by Tom Trenka

Priority: highnormal

Also removing the "high" priority.

comment:3 Changed 11 years ago by Adam Peller

Owner: changed from Tom Trenka to Adam Peller

comment:4 Changed 11 years ago by liucougar

just want to mention chinese calendar here as well :)

http://en.wikipedia.org/wiki/Chinese_calendar

comment:5 Changed 11 years ago by dylan

Milestone: 1.3

comment:6 Changed 11 years ago by Adam Peller

Cc: hossamt@… added
Description: modified (diff)

see [13291] Thanks, Hossam!

comment:7 Changed 11 years ago by Adam Peller

(In [13354]) Hebrew Calendar initial implementation, from Hossam Aldin Katory (IBM). Refs #5074 !strict

comment:8 Changed 11 years ago by Adam Peller

Milestone: 1.31.2
Resolution: fixed
Status: newclosed

Changed 10 years ago by Adam Peller

Attachment: dijit5074.patch added

Initial patch to Dijit to support 'datePackage' by Helena Halperin (IBM-IL, CCLA). Needs further review.

Changed 10 years ago by Adam Peller

Attachment: hebrew5074.patch added

dojox.date.hebrew refactor by Helena Halperin (IBM-IL, CCLA) to support 'datePackage' in Dijit. Needs further review.

comment:9 Changed 10 years ago by Adam Peller

Cc: hhelena@… added
Milestone: 1.21.4
Resolution: fixed
Status: closedreopened

comment:10 Changed 10 years ago by Adam Peller

bill points out that the conversion in postMixInProperties for this.value should be moved to _setValueAttr

comment:11 Changed 10 years ago by Adam Peller

Resolution: fixed
Status: reopenedclosed

Applied Helena's changes to dijit in [17172] to allow for generic calendar support. Still need refactor of dojox.date.islamic code.

comment:12 Changed 10 years ago by Adam Peller

(In [18865]) Refactor Islamic Date code to match other national calendars. Refs #5074 !strict

comment:13 Changed 10 years ago by Adam Peller

Initial Islamic calendar code, from Hossam Katory (IBM, CCLA) checked in [13291]

comment:14 Changed 9 years ago by Adam Peller

(In [21602]) Fixes regression in goToToday() from r17172. Fixes #10864, refs #5074 !strict

comment:15 Changed 7 years ago by bill

The datePackage attribute doesn't work well in the AMD world. The problem is that it's overloaded as a way to load two modules: (for example) dojox/date/hebrew.js and dojox/date/hebrew/locale.js. Because of this, after I cleaned up the dojo/date.js module export value in [28655], things like _DateTimeTextBox stopped working.

The only solution I see is to have two attributes, one for each module: dateModule and dateLocaleModule. I'll check that in unless someone has a better idea.

Last edited 7 years ago by bill (previous) (diff)

comment:16 Changed 7 years ago by bill

In [28684]:

Although dojo.date.locale is accessible via the dojo.date global (until 2.0), it can't be accessed from the dojo/date module export, at least after [28655].

Thus the "datePackage" widget parameter is architecturally flawed, because it's overloaded to specify both the dojo/date and dojo/date/locale modules. Leaving it in place until 2.0, but at that point it should be replaced by dateModule and dateLocalModule parameters specifying MID's (or directly specifying Objects). Alternately we should just get rid of it since the AMD loader supports remapping of module ids, so that dojo/date could be remapped to dojox/date/hebrew (etc.) by the application.

Refs #5074, #13494 !strict.

comment:17 Changed 4 years ago by Bill Keese <bill@…>

In c6d9f7bb6578fc6e22a19fc1175e24094a39ebb9/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:18 Changed 4 years ago by Bill Keese <bill@…>

In e3c79a352abfc5f9350dc3336eb83c51868e3011/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.