Opened 12 years ago

Closed 12 years ago

#5072 closed enhancement (wontfix)

content is shown before tabs are loaded

Reported by: guest Owned by:
Priority: high Milestone: 1.0.1
Component: Dijit Version: 1.0
Keywords: TabContainer Cc:
Blocked By: Blocking:

Description

On slow connections (or big tab-contents) there is the phenomenon that before the tabs are loaded, a part of the content is already shown (without tabs). The result is: the user gets the whole content (even the one, who is hiding in other tabs - after they're loaded) and finaly sees the "transformation" into the tabs.

Change History (1)

comment:1 Changed 12 years ago by bill

Resolution: wontfix
Status: newclosed

You need to set style="display: none" on the hidden tabs (or on all the tabs maybe), or just hide everything on the page until parsing is finished, like themeTester.html does. This is by design.

Note: See TracTickets for help on using tickets.