Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5070 closed defect (fixed)

mail demo fails when viewed within web site

Reported by: dylan Owned by: bill
Priority: high Milestone: 1.0.1
Component: Website Version: 1.0
Keywords: Cc: bill
Blocked By: Blocking:

Description

http://dojotoolkit.org/demos/email-using-1-0

Drupal's inclusion of jQuery appears to be breaking the mail demo:

Per pottedmeat, this is the offensive line.

if ($.browser.msie == true) { document.execCommand('BackgroundImageCache?', false, true); }

Per a comment on the demo page:

The pages errors at this:

dijit.byId('fakeFetch').update({ indeterminate: false });

Per Kevin Hakman of TIBCO, on IE 6.0.2900.2180 you get the lovely "object doesn't support this property or method error" on line 63, char (3) (Pretty useless info).

Marking this as pretty high priority, because errors in one of our main demos make us look bad.

Change History (7)

comment:1 Changed 12 years ago by dylan

Milestone: 1.0.1
Version: 0.91.0

comment:2 Changed 12 years ago by bill

Wow, that's a weird one. I'm guessing it fails setting CSS class "dijitProgressBarIndeterminate" on the progress bar, which pulls in "images/dijitProgressBarAnim.gif". Probably because it's an animated gif and that's triggering some IE bug. In which case maybe should just not use the animated gif for IE6 (but still use for other browsers including IE7)?

comment:3 Changed 12 years ago by bill

Owner: changed from tk to bill
Status: newassigned

comment:4 Changed 12 years ago by bill

Hmm, I'm having a lot of trouble reproducing this. I made a page that includes jquery and then brings up the mail demo in an iframe, but no errors. And I don't even see a reference to BackgroundImageCache? in http://jqueryjs.googlecode.com/files/jquery-1.2.1.js

What am I missing?

comment:5 Changed 12 years ago by bill

The jquery thing looks like it was a red herring, since besides the reason listed above, dojo/html.js itself calls {{{ document.execCommand('BackgroundImageCache??', false, true); }}} The real issue seems to have been #5131, but will work around the problem for now by setting isDebug: false on the demo page.

comment:6 Changed 12 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [11510]) Fixes #5070 on trunk: isDebug: true page in an iframe fails if root page loads dojo with isDebug: false

comment:7 Changed 12 years ago by bill

(In [11511]) Fixes #5070 on 1.0 branch: isDebug: true page in an iframe fails if root page loads dojo with isDebug: false

Note: See TracTickets for help on using tickets.