Opened 12 years ago

Closed 6 years ago

#5051 closed defect (worksforme)

Safari graphic text and events problems

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: future
Component: DojoX GFX Version: 0.9
Keywords: needsreview Cc:
Blocked By: Blocking:

Description (last modified by ben hockey)

I have the following piece of code the problem is when scrolling down to look at the text it does not show up.

Also there is a problem with connect, as it does not function properly I'm using the safari windows version 3.0.3 (522.15.5). Not sure if it's a dojo or safari issue.

dojo.require("dojox.gfx");

init = function(){
	var container = dojo.byId("gfx");
	var surface = dojox.gfx.createSurface(container, 500, 500);


        var group1 = surface.createGroup();

        var a = group1.createRect({x:50, y:50, width:20, height:20});
        a.setFill( "gray" );

	var b = group1.createText({x:50, y: 50, text: "123", align: "middle"});
	b.setFont({family: "Verdana", size: 10, weight: "bold"});
	b.setFill("blue");

        var c = surface.createRect({x:400, y:400, width:20, height:20});
        c.setFill( "gray" );


	var d = surface.createText({x:400, y: 400, text: "123", align: "middle"});
	d.setFont({family: "Verdana", size: 10, weight: "bold"});
	d.setFill("blue");

	dojo.connect(a.getNode(), "onmouseover", function(){
          alert("a");
        });

	dojo.connect(b.getNode(), "onmouseover", function(){
          alert("b");
        });

	dojo.connect(c.getNode(), "onmouseover", function(){
          alert("c");
        });

	dojo.connect(d.getNode(), "onmouseover", function(){
          alert("d");
        });
};

dojo.addOnLoad(init);

Attachments (2)

shapes.svg (1.7 KB) - added by guest 12 years ago.
svg file needed for test.html
test.html (416 bytes) - added by guest 12 years ago.
main file to run svg

Download all attachments as: .zip

Change History (11)

comment:1 Changed 12 years ago by guest

Sorry it's already being reported regarding the text problem, but I don't think the connect issue has.

comment:2 Changed 12 years ago by guest

Sorry forgot to attach the html bit...

<html> <head> <title>123</title> <script type="text/javascript" src="dojo/dojo.js"></script> your javascript here </head> <body>

<div id="gfx" style="overflow: auto; height:300px; width:100%;"></div>

</body> </html>

comment:3 Changed 12 years ago by Eugene Lazutkin

Milestone: 1.1
Status: newassigned
Summary: Safri graphic text problemsSafari graphic text and events problems

Actually both problems are well-known. Please file bugs with Webkit: http://bugs.webkit.org/

I don't close this ticket now, because I want to create a test program for different events --- I use this ticket as a reminder.

comment:4 Changed 12 years ago by guest

I have created a bug report...

http://bugs.webkit.org/show_bug.cgi?id=15920

Please add to it if you think I have not made myself clear regarding the problem.

Changed 12 years ago by guest

Attachment: shapes.svg added

svg file needed for test.html

Changed 12 years ago by guest

Attachment: test.html added

main file to run svg

comment:5 in reply to:  4 Changed 12 years ago by guest

elazutkin you may be intrested to take a look at my SVG example. I have a bunch of shapes and text created in svg* (not using dojo) and put it under a height and the text problem does not occur in safari.

Please take a look at test.html.

*got this code from : http://www.carto.net/papers/svg/samples/shapes.shtml

comment:6 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.11.2

comment:7 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.2future

Moving all open ticketd to the future.

comment:8 Changed 7 years ago by ben hockey

Description: modified (diff)
Keywords: needsreview added

comment:9 Changed 6 years ago by Patrick Ruzand

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.