Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5046 closed defect (duplicate)

contentPane doesn't work properly in dojo 1.0.0

Reported by: guest Owned by:
Priority: high Milestone:
Component: Dijit Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

contentPane doesn't work in dojo 1.0.0.I use contentPane to lay my page,when I use contentPane like this <div dojoType="dijit.layout.ContentPane?" layoutAlign="bottom" >footer</div>,it doesn't work properly.I want this div always show in the bottom of the page .but when I change the page size, its position also changes.In IE 6.0,this div appears in the top of the page ,and in firefox 2.0,this div disappears.the following is my code.

<!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.0 TransitionalEN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml"> <head>

<title>Master Page</title> <style type="text/css">

@import "js/dijit/themes/tundra/tundra.css"; @import "js/dojo/resources/dojo.css"

</style>

<script type="text/javascript" src="js/dojo/dojo.js" djconfig="parseOnLoad: true,isDebug:false"></script>

<script type="text/javascript">

dojo.require("dojo.parser"); dojo.require("dijit.layout.SplitContainer?"); dojo.require("dijit.layout.LayoutContainer?"); dojo.require("dijit.layout.ContentPane?");

</script>

</head> <body class="tundra">

<div dojotype="dijit.layout.LayoutContainer?">

<div dojotype="dijit.layout.ContentPane?" layoutalign="top" style="background-color: Red">

Home Page

</div> <div dojotype="dijit.layout.LayoutContainer?" layoutalign="client" style="background-color: Yellow">

<div dojotype="dijit.layout.LayoutContainer?" layoutalign="left" style="background-color: yellow;

width: 120px"> dijit left

</div> <div id="practitioners" dojotype="dijit.layout.LayoutContainer?" layoutalign="client">

dijit right;

</div>

</div>

<div dojoType="dijit.layout.ContentPane?" layoutAlign="bottom" style="background-color: lightblue" >

footer

</div>

</div>

</body> </html>

Change History (2)

comment:1 Changed 12 years ago by bill

Resolution: duplicate
Status: newclosed

Invalid, and duplicate of #5045.

comment:2 Changed 12 years ago by bill

Milestone: 1.0.1
Note: See TracTickets for help on using tickets.