Opened 12 years ago

Closed 12 years ago

#5038 closed defect (duplicate)

bug when the dimension of a dojo.gfx.Surface changed (vml.js only)

Reported by: guest Owned by: Eugene Lazutkin
Priority: low Milestone:
Component: DojoX GFX Version: 1.0
Keywords: gfx vml dimension Cc:
Blocked By: Blocking:

Description

My program needs to change the dimension of a gfx surface dynamically. I invoked the setDimensions() method of a VML dojox.gfx.Surface object to a wider dimension, and I expect the shapes should be able to be drawn in the new area. However, those shapes outside the original dimension didn't show up. (svg works fine.)

I added the following lines into the dojox.gfx.Surface.setDimensions() method in the vml.js to fix the bug:

this.clipNode.style.width = width;
this.clipNode.style.height = height;
this.clipNode.style.clip = "rect(0 " + width + " " + height + " 0)";

Change History (1)

comment:1 Changed 12 years ago by Eugene Lazutkin

Resolution: duplicate
Status: newclosed

Duplicate of #5035, which was fixed today. New test_resize.html was created to test for the problem.

Note: See TracTickets for help on using tickets.