Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#5025 closed defect (invalid)

CSS-class width property doesn't work on ValidationTextBox

Reported by: guest Owned by:
Priority: high Milestone:
Component: Dijit - Form Version: 1.0
Keywords: validation textbox width html Cc:
Blocked By: Blocking:

Description

Hello,

I tried to migrate from dojo 0.9 to 1.0 today and discovered some problems in connection with dijit ValidationTextBox?.

With dojo 0.9 I already used a CSS class to define the text-box-width:

input.textbox {

width:400px;

}

But with dojo 1.0 this is not working anymore on the dijit ValidationTextBox?.

If I define the width-style attribute (e.g. style="width:400px") in the input-tag, everything works fine.

I took a look with firebug to the generated HTML-code for the ValidationTextBox? and discovered, that the problem is related to the surrounding table, which includes the input-field and the warning-icon. This table also uses the CSS-class, defined for the input-field.

If I define an additional CSS-class for this table:

table.textbox {

width:400px;

}

everything is ok. But I think this is not the way it is meant to be.

Best regards,

Holger Rath

Change History (2)

comment:1 Changed 12 years ago by bill

Resolution: invalid
Status: newclosed

That is the way it's meant to be. Please reference the porting guide: http://dojotoolkit.org/book/dojo-porting-guide-0-9-x-1-0/dijit

comment:2 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.