Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#5013 closed defect (fixed)

mail demo shows up wrong on safari

Reported by: bill Owned by: bill
Priority: high Milestone: 1.0.1
Component: Dijit Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

See http://download.dojotoolkit.org/release-1.0.0/dojo-release-1.0.0/dijit/demos/mail.html on safari. Initial sizing is wrong, but rights itself if you resize the browser window.

Attachments (1)

5013.png (55.8 KB) - added by bill 12 years ago.
screenshot of safari

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by bill

Milestone: 1.11.0.1

comment:2 Changed 12 years ago by Douglas Hays

Seems to be good the first time the page is loaded, but when I click the safari reload button, then it's rendered incorrectly.

comment:3 Changed 12 years ago by bill

It's a race condition... for me it works locally but not from dojotoolkit.org. Apparently the problem is that the layout code executes before mail.css has been loaded, thus this critical rule is not in effect when layout is done:

html, body, #main{	
	width: 100%;	/* make the body expand to fill the visible window */
	height: 100%;
	overflow: hidden;	/* erase window level scrollbars */
	padding: 0 0 0 0;
	margin: 0 0 0 0;
	font: 10pt Arial,Myriad,Tahoma,Verdana,sans-serif;
}

On my machine it thinks that the main div's height is 92px, because that's it's natural height without CSS styling.

comment:4 Changed 12 years ago by bill

Owner: set to bill
Status: newassigned

Changed 12 years ago by bill

Attachment: 5013.png added

screenshot of safari

comment:5 Changed 12 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [11514]) Fixes #5013 on 1.0 branch: this is just a workaround to bug #5136, a race condition where widgets initialize before CSS has finished downloading

comment:6 Changed 12 years ago by bill

(In [11515]) Fixes #5013 on trunk: this is just a workaround to bug #5136, a race condition where widgets initialize before CSS has finished downloading

comment:7 Changed 12 years ago by bill

Note that I changed the fix after the above checkin, see [11591] and [11592]. Simply loading the CSS before loading dojo.js works around the race condition.

Note: See TracTickets for help on using tickets.