Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#5006 closed defect (fixed)

ComboBox in a TooltipDialog: value only visible when it has focus or the mouse pointer is hovered over it (IE7)

Reported by: simonjb Owned by: bill
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by simonjb)

On IE7 the value of a ComboBox in a TooltipDialog is only visible whenever the ComboBox has focus or the mouse pointer is hovered over it. To reproduce:

  1. open dijit/tests/test_Dialog.html
  2. click on the "Show Tooltip Dialog" button
  3. when the dialog box opens, the Pizza field appears to have no value
  4. hover the mouse pointer over the ComboBox
  5. value appears
  6. move mouse pointer away from ComboBox and over another form field in the dialog
  7. value disappears

Change History (8)

comment:1 Changed 12 years ago by Douglas Hays

Possibly related: on FF2/WinXP, clicking the pizza combobox arrow the 1st time causes the arrow to shift left dramatically, and clicking a 2nd time, moves it back right.

comment:2 Changed 12 years ago by bill

Working for me on IE6 but not IE7; I suspect you are running IE6 stand-alone which isn't quite as stand-alone as it claims. In any case, yuck, bad bug. The width=100% <td> has 0px width. I found this out via IE Dom explorer, tracing thru the tree of DOM nodes until I found the right one (it's in the 5th div from the end).

comment:3 Changed 12 years ago by bill

Summary: ComboBox in a TooltipDialog: value only visible on IE6 and IE7 when it has focus or the mouse pointer is hovered over itComboBox in a TooltipDialog: value only visible when it has focus or the mouse pointer is hovered over it (IE7)

Filed #5007 for bug Doug mentioned above.

comment:4 Changed 12 years ago by simonjb

Description: modified (diff)

Bill, you're right: 'stand-alone' IE6.

comment:5 Changed 12 years ago by Douglas Hays

I removed the following rule from dijit.css and the problem went away on IE7:

.dijitTooltipDialog {
        position: relative;
}

Unfortunateloy I don't know if that rule is needed and what the side-effects of removing it are.

comment:6 Changed 12 years ago by bill

Hmm, interesting. That position: relative; CSS is there so we can position the tooltip's content box and the little triangle (that points to the button). Might be able to do it a different way, although it's complicated since the triangle can appear in many positions (top, bottom, left, right).

comment:7 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [11390]) Fixes #5006: ComboBox? in a TooltipDialog?: value only visible when it has focus or the mouse pointer is hovered over it (IE7) Thanks Doug for the fix! For some reason removing the position:relative on the dijitTooltipDialog <div> avoids an IE table sizing bug. Without that position:relative the positioning of the triangle and tooltip contents becomes relative the dijitPopup <div> rather than the dijitTooltipDialog <div>, but since dijitPopup just encloses the dijitPopup it amounts to the same thing.

comment:8 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.