Opened 12 years ago

Closed 12 years ago

#4961 closed defect (duplicate)

cometd wildcard support

Reported by: guest Owned by: alex
Priority: high Milestone: 1.2
Component: DojoX Cometd Version: 0.9
Keywords: cometd wildcard Cc:
Blocked By: Blocking:

Description (last modified by alex)

I'm not sure whether or not the wild(wild)card support described in bayeux protocol is implemented or not but for me. The dojo connect.js is unaware of wildcard, but I can't find the logic in cometd.js either. Here's the section where I implemented myself a non patch worthy hack.

236 	                if(message.data){
237 	                        // dispatch the message to any locally subscribed listeners
238 	                        var tname = (this.globalTopicChannels[message.channel]) ? message.channel : "/cometd"+message.channel;
239 	                        dojo.publish(tname, [ message ]);
240 	                }

This is the closest comment over the issue that I could find <http://trac.dojotoolkit.org/changeset/4788>.

Change History (4)

comment:1 Changed 12 years ago by Tom Trenka

Owner: changed from Tom Trenka to alex

comment:2 Changed 12 years ago by dylan

Milestone: 1.2

comment:3 Changed 12 years ago by alex

Component: DojoxDojoX Cometd
Description: modified (diff)

comment:4 Changed 12 years ago by dylan

Resolution: duplicate
Status: newclosed

Duplicate of #5963.

Note: See TracTickets for help on using tickets.