Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4941 closed defect (duplicate)

[Dijit][FilteringSelect] onChange handler does not work for the first selection

Reported by: guest Owned by:
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 1.0
Keywords: FilteringSelect Cc: freemanlong@…; justicejiang@…
Blocked By: Blocking:

Description

I have just try the dojo 1.0 beta version, and find out this bug by chance.

When you set an empty value or set no value for the FilteringSelect? component, the onChange event will not be fire when you choosing your first choice.

I have exameine the source code and I believe it is caused by the dojo._listener.getDispatcher() method which make the onChange event not fire properly for the first selection.

Furthermore, thought haven't been tested, the ComboBox? component might have the same problem.

Change History (2)

comment:1 Changed 12 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #4937

comment:2 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.