Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4934 closed defect (fixed)

cannot select text inside a dialog

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.0.1
Component: DnD Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

You are unable to select any text in form dijits, plain input's, or just boilerplate text that is inside a dialog.

This happens when using IE7, not FF.

I get the same behavior in the archives at "dojotoolkit/dijit/tests/test_Dialog.html".

This behavior starts with the dojo-2007-10-24 build.

Change History (6)

comment:1 Changed 12 years ago by bill

Description: modified (diff)
Summary: cannot select text in form dijits inside a dialogcannot select text inside a dialog

comment:2 Changed 12 years ago by bill

Component: DijitDnD
Milestone: 1.1
Owner: set to Eugene Lazutkin

Eugene, can I give this one to you? It's caused by the DnD move code, which apparently disables selection not only on the drag handle but on the whole object being dragged (since the 10/24 build)

comment:3 Changed 12 years ago by guest

This worked in the 1.0 beta, so this issue was introduced between then and 1.0 release. I'm a little supprised that this won't be addressed until 1.1 as it's basic functionality for a textbox in a dialog.

-Dave mannd@…

comment:4 Changed 12 years ago by Eugene Lazutkin

Resolution: fixed
Status: newclosed

(In [11414]) dnd: fixing missed renames. Fixes #4934.

comment:5 Changed 12 years ago by Eugene Lazutkin

(In [11421]) dnd: fixing in 1.0 branch, refs #4934.

comment:6 Changed 12 years ago by bill

Milestone: 1.11.0.1
Note: See TracTickets for help on using tickets.