Opened 12 years ago

Closed 12 years ago

#4930 closed defect (worksforme)

Grid editing appears broken - "inRowIndex is not defined"

Reported by: guest Owned by: sorvell
Priority: high Milestone: 1.0
Component: DojoX Grid Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Adam Peller)

In the 10/29/07 nightly build, if I go to test_edit.html and try to edit a cell, I get a Javascript error:

"inRowIndex is not defined"

Firefox 2 + Firebug 1.1b says the error occurs at model.js line 174:

inRowIndex is not defined
copyRow()model.js (line 174)
beginModifyRow(0)model.js (line 119)
doStartEdit(Object width=100% editor=Object name=Message, 0)Grid.js (line 157)
start(Object width=100% editor=Object name=Message, 0, true)edit.js (line 134)
setEditCell(Object width=100% editor=Object name=Message, 0)edit.js (line 92)
onCellDblClick(dblclick clientX=0, clientY=0)publicEvents.js (line 145)
dodblclick(dblclick clientX=0, clientY=0)VirtualGrid.js (line 541)
_dispatch("dodblclick", dblclick clientX=0, clientY=0)VirtualGrid.js (line 517)
dispatchContentEvent(dblclick clientX=0, clientY=0)VirtualGrid.js (line 524)
onContentEvent(dblclick clientX=0, clientY=0)publicEvents.js (line 18)
doContentEvent(dblclick clientX=0, clientY=0)view.js (line 231)
toString()dojo.js (line 20)
[Break on this error] this.getRow(inRowIndex).slice(0);

IE 7 gives the same error, but calls it line 175.

Change History (2)

comment:1 Changed 12 years ago by Adam Peller

Component: GeneralDojoX Grid
Description: modified (diff)
Owner: changed from anonymous to sorvell

comment:2 Changed 12 years ago by Adam Peller

Resolution: worksforme
Status: newclosed

I tried here and do not see any exceptions

http://archive.dojotoolkit.org/dojo-2007-10-29/dojotoolkit/dojox/grid/tests/test_edit.html

but I did see data disappear when editing - perhaps firebug wasn't catching the exception or something?

using the trunk today, it all seems to work fine.

Note: See TracTickets for help on using tickets.