Opened 14 years ago

Closed 14 years ago

Last modified 12 years ago

#492 closed defect (fixed)

IE hangs for test_Button2.html, test_FloatingPane.html (etc.?)

Reported by: bill Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.2
Keywords: Cc:
Blocked By: Blocking:

Description

No idea where the bug is but as of IE hangs loading tests/widget/test_Button2.html

Same problem for test_FloatingPane.html.

Marking as critical as this seems to be a general issue, not just a problem with a single widget. Might have something to do with loading lots of images simultaneously.

http://archive.dojotoolkit.org/dojo-2006-03-03/tests/widget/test_Button2.html http://archive.dojotoolkit.org/dojo-2006-03-03/tests/widget/test_FloatingPane.html

Change History (3)

comment:1 Changed 14 years ago by Morris Johns

I had a look into this for test_FloatingPane.html

If you have a look at the HTTP traffic, you see that there are some requests that don't make any sense. There are multiple requests for: http://archive.dojotoolkit.org/nightly/tests/widget/ which is a valid webpage on dojotoolkit and returns the directory listing for that directory. This html hangs IE for whatever reason. When you run the test from the local file system (or a web server without directory browsing enabled) the request for the above url gets a 404 and the test works properly with IE.

The cause is the following line in the template: <img dojoAttachPoint="titleBarIcon" src="${this.iconSrc}" class="dojoTitleBarIcon">

I used a proxy-hack to remove src="${this.iconSrc}" while running from dojotoolkit.org, and the page loaded just fine in IE! Pretty sure that is the offending code!

Perhaps we could add detection for HTML returned instead of CSS if debug mode is on?

[Note: IE also makes 10 requests for http://archive.dojotoolkit.org/nightly/tests/widget/url() but that is an unrelated issue - FF also has a single request for that url for the test_FloatingPane.html. Probably something to do with the tree that has ten items.]

Bill thought they came from css urls (and from the HTTP traffic I think so also).

comment:2 Changed 14 years ago by bill

Resolution: fixed
Status: newclosed

test_floatingPane.html fixed in checkin #3288. who would have suspected that <img src=""> can hang IE???

comment:3 Changed 12 years ago by (none)

Milestone: 0.3release

Milestone 0.3release deleted

Note: See TracTickets for help on using tickets.