Opened 12 years ago

Closed 12 years ago

#4884 closed enhancement (duplicate)

while performing dnd when I Drag someting that particular dnd Item should get disaapper and whever I will try to drop it should show dooted area of same height and width of selected dndtem.

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.0
Component: DnD Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Eugene Lazutkin)

I am using Dojo "dojo-release-0.9.0" version. In this as per track enhancement request no 4840 my "dnd on click of top menu bar" requirement is fullfilled but I am facing one more issue. while performing dnd when I Drag someting that particular dnd Item should get disappear and below items in that verticle section should get rearranged and wherever I will try to drop it should show dooted area of same height and width of selected dndtem to drop.While dropping also the items in that section should get rearranged .Can anybody help on this enhancement.the code is as follows : Details : for Ex : If I drag "Test Info 1" dndItem then before dropping it immediatley aftr I drag Test No 1 ,items below it , here in this ex: Test no 2 should immediately shift to place of Test No 1 and Test No 3 should shift immediately to place of Test no 2. It means immediate rearrangement of all these dndItems should get Possible. Also aftr dragging Test no 1 if I tries to drop it at For Ex: Test no 5 then it should show dooted are of same height nad width needed for dragged item (Test no 1 ) and Test no 5 should immediately shift down to Test no6 and text No 6 to next down position. The current dnd files doesnt support this. can this enhancement possible. Waiting for solution.

Code is as follows: [reducted].

Attachments (3)

testHTMLPageforDojoBlueHighlighting.html (47.5 KB) - added by guest 12 years ago.
Html page code I used
4884-enhancement-dnd--req-1.gif (41.6 KB) - added by guest 12 years ago.
Scrren shot 1 to explain enhancement
4884-enhancement-dnd--req-2.gif (25.3 KB) - added by guest 12 years ago.
Scrren Shot 2 to explain enhancement in sequenc of earlier Screen shot 1

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by guest

Html page code I used

Changed 12 years ago by guest

Scrren shot 1 to explain enhancement

Changed 12 years ago by guest

Scrren Shot 2 to explain enhancement in sequenc of earlier Screen shot 1

comment:1 Changed 12 years ago by guest

along with earlier html attachemnet file I am adding two more attachements "4884-enhancement-dnd--req-1.gif" and "4884-enhancement-dnd--req-2.gif" in sequence so that it will help to understand what enhancement I am trying to explain.

Here I am facing one more problem that select box from Test Info 2 is getting displayed in Avatar or translucent of Test Info 1 . Can you help on this.Plz see attached Screen shots (4884-enhancement-dnd--req-1.gif)

Can you plz help on this.

Waiting for Feedbcak on hightest priority.

Thanks.

comment:2 Changed 12 years ago by Eugene Lazutkin

Cc: eugene removed
Description: modified (diff)
Keywords: while performing dnd when I Drag someting that particular dnd Item should get disaapper and whever I will try to drop it should show dooted area of same height and width of selected dndtem. removed
Milestone: 1.0
Priority: highestnormal
severity: majornormal

comment:3 Changed 12 years ago by Eugene Lazutkin

Resolution: duplicate
Status: newclosed

This is a duplicate of #3696. It is a nice-to-have but rarely requested feature. BTW, it is entirely possible to implement it with a custom code.

I'll file an enhancement ticket for the control bleeding you mentioned. It will not be in for 1.0 because this is the browser problem and while workaround is known it is relatively heavy-weight to implement (requires an iframe).

Note: See TracTickets for help on using tickets.