Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#4883 closed defect (duplicate)

problem while performing drag and drop , blue highlighting, most of part gets selected.

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.2
Component: DnD Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Eugene Lazutkin)

Problem details - While performing drag and drop most of the part of page gets selected.It shows blue highlighting. When you click somewhere it goes off. How to reproduce bug - If you selects anything in this following code,left top most item from the First Section For Ex:Test Info 1 dndItem and tries to drop it in the Second or Third Section after existing items in that Sections, then the most of the rest dnditems from all/or coming across sections gets selected and it shows blue hightligting just like if we select anything with mouse on any page.Aftr dragging a item when u drop it somewhere and then click anywhere on page it goes off.

When I mentioned this problem on Forum I felt that it might be because of heavy loaded jsp page or the images which I have used in css are gif not png. But my this doubt is also cleared becaz I converted same page into HTML skipping all jsp/Ajax/j2ee code then also I faced similar problem of blue highkighting in html page also. The same page/code is as follows.

Attachments (16)

testHTMLPageforDojoBlueHighlighting.html (47.5 KB) - added by guest 12 years ago.
testHTMLPageforDojoBlueHighlighting.html
blue-highlighting-1.gif (27.8 KB) - added by guest 12 years ago.
blue-highlighting-2.gif (23.0 KB) - added by guest 12 years ago.
dnd-blueHighlighting-In-IEBrowser.html (12.1 KB) - added by guest 12 years ago.
Simplified Html Code form earlier one to show Blue highlighting problem in IE browser.
dnd-blueHighlighting-1.gif (27.7 KB) - added by guest 12 years ago.
Screen shot to show Blue highlighting problem in IE browser with simplified code than earlier
sample 1.html (13.3 KB) - added by guest 12 years ago.
Sample file to show why I used doh.runner
test_dnd_handles.html (3.7 KB) - added by guest 12 years ago.
As per suggested by you I have tried to modify existing test_XXX.html file
test_dnd_handles_duplicate.html (3.7 KB) - added by guest 12 years ago.
I tried same file with little modifications
test_dnd_handles1.html (6.0 KB) - added by guest 12 years ago.
I tried same file with little more modifications and again faced same Blue highlighting problem
sample-1_problem.gif (31.7 KB) - added by guest 12 years ago.
to show same Blue highlighting problem
test_cnd_handles_duplicate_.gif (33.5 KB) - added by guest 12 years ago.
to show same Blue highlighting problem
test_dnd_handles1_problem.gif (40.6 KB) - added by guest 12 years ago.
to show same blue highlighting problem
test1.gif (28.9 KB) - added by guest 12 years ago.
for blue highlighting dojo version 1.0
test1.2.gif (28.9 KB) - added by guest 12 years ago.
for blue highlighting dojo version 1.0
test2.gif (31.6 KB) - added by guest 12 years ago.
for blue highlighting dojo version 1.0
test_dnd_handles_NewVersion.html (3.9 KB) - added by guest 12 years ago.
for blue highlighting dojo version 1.0

Download all attachments as: .zip

Change History (33)

Changed 12 years ago by guest

testHTMLPageforDojoBlueHighlighting.html

Changed 12 years ago by guest

Attachment: blue-highlighting-1.gif added

Changed 12 years ago by guest

Attachment: blue-highlighting-2.gif added

comment:1 Changed 12 years ago by guest

I am attaching the scrren shots so that you can easily see the problems i have faced. Plz see the attachements blue-highlighting-1.gif and blue-highlighting-2.gif in additon to earlier html code attachement file testHTMLPageforDojoBlueHighlighting.html .

Waiting for feedback. Thanks.

comment:2 Changed 12 years ago by guest

Also I faced that it doesnt do dnd drag and drop smoothly , is it the problem with the dojo Implementation I used verion "dojo-release-0.9.0".

Waiting for feedback on highest priority. Thanks.

comment:3 Changed 12 years ago by Eugene Lazutkin

Cc: eugene removed
Description: modified (diff)
Keywords: while performing drag and drop blue highlighting most of part gets selected removed
Priority: highestnormal
severity: majornormal

comment:4 Changed 12 years ago by Eugene Lazutkin

Milestone: 1.0
Status: newassigned

Bugs in the example. When fixed it works for me.

comment:5 Changed 12 years ago by Eugene Lazutkin

See this forum discussion for details.

comment:6 Changed 12 years ago by Eugene Lazutkin

Resolution: worksforme
Status: assignedclosed

Changed 12 years ago by guest

Simplified Html Code form earlier one to show Blue highlighting problem in IE browser.

Changed 12 years ago by guest

Attachment: dnd-blueHighlighting-1.gif added

Screen shot to show Blue highlighting problem in IE browser with simplified code than earlier

comment:7 Changed 12 years ago by guest

Resolution: worksforme
Status: closedreopened

You have said that its related to showhide function and it worked from your side when you defined dummy function. Yes it was giving error related to this function since it was not defined in that code. But I tried from myside again. Blue highlighting problem is not becaz of this. Aftr you mentioned abt few questions as follows: 1) On what browser do you see the problem? IE only? All of them? I crosschecked that this problem arries only on IE. Here i am attaching more simplified version of my code which will make easy from your side to go through it. Plz see the code. The problem is still ther in IE browser.Only sometimes it works otherwise it again gives Blue highlighting.

2)Do dojo/tests/dnd/test_XXX.html files show the same problem? In this case(dojo/tests/dnd/test_XXX.html files ) I havnt observed the Blue highlighting problem becaz you have used very little HTML text to show as a data as an exapmle where as in my pages depending upon data lot much data needs to be shown in jsp/HTML as compared to dojo/tests/dnd/test_XXX.html files .

3)to reproduce the same problem with smaller amount of text - I have simplified my code and copied it as follows. To reproduce the same problem keep on dragging again and again from first Section to Second Section Test info 1, Test info 2. Only sometimes it works otherwise it again gives Blue highkighting in IE browser.

4)drag and drop doesnt work smoothly in IE browser if data is more.

I have reopened the ticket 4883 and attached the Simplied HTMLcode(dnd-blueHighlighting-In-IEBrowser.html) from earlier attached code and screen shot for this (dnd-blueHighlighting-1.gif)

Please look at this matter again.

Waiting for your help. Thanks.

comment:8 Changed 12 years ago by Eugene Lazutkin

Answers by numbers:

  1. OK.
  2. Try to modify existing test_XXX.html files until they show the same problem. If you can't, problem is in your code.
  3. I dragged items in your sample file back and forth for 10 minutes and was not able to reproduce the problem.
  4. I noticed it too. I suggest to file a bug with Microsoft on that.

What Dojo do you use: from the trunk or the release archive? Why do you use "doh.runner" in your code?

Changed 12 years ago by guest

Attachment: sample 1.html added

Sample file to show why I used doh.runner

Changed 12 years ago by guest

Attachment: test_dnd_handles.html added

As per suggested by you I have tried to modify existing test_XXX.html file

Changed 12 years ago by guest

I tried same file with little modifications

Changed 12 years ago by guest

Attachment: test_dnd_handles1.html added

I tried same file with little more modifications and again faced same Blue highlighting problem

Changed 12 years ago by guest

Attachment: sample-1_problem.gif added

to show same Blue highlighting problem

Changed 12 years ago by guest

to show same Blue highlighting problem

Changed 12 years ago by guest

to show same blue highlighting problem

comment:9 Changed 12 years ago by guest

Answers by numbers From My Side:

1) Still same condition

2) As per suggested by you I have tried to modify existing test_XXX.html files until they show the same problem.

I used file "dojo-release-0.9.0dojo estsdnd est_dnd_handles.html" provied by you people.

(a) In test_dnd_handles.html not found problem in this as I have told to you earlier(...you have used very little HTML text to show as a data as an exapmle where as in my pages depending upon data lot much data needs to be shown in jsp/HTML as compared to dojo/tests/dnd/test_XXX.html files .)

(b) I tried same file with little modifications where I faced the Blue Highlighting problem very very rarely.( attached file "test_dnd_handles_duplicate.html").

(c) I tried same file with little more modifications and again faced same Blue highlighting problem. ( attached file "test_dnd_handles1.html")

You have mentioned this "Try to modify existing test_XXX.html files until they show the same problem. If you can't, problem is in your code " . so from My Side in the modified version ("test_dnd_handles1.html") of "test_dnd_handles.html" I faced same "Blue Highlighting problem". See attachements.

In all this I again observed one more point that while doing drag and drop horizontaly or diagonaly from top left corener towards the direction of bottom right corner the frequency of problem is more. Where as if you drag and drop verticaly in the same one particular section then in that case problem is not observed.

3) Still same condition.

4) are you filing a bug with Microsoft on that ?

What Dojo do you use: from the trunk or the release archive? Ans : I am using the dojo "dojo-release-0.9.0" downloaded from site "http://dojotoolkit.org/downloads" in last month. It doent mention whether its "from the trunk or the release archive?". Can you plz tell me answer of this question and do the problem is becaz of this?

Why do you use "doh.runner" in your code? Ans :I used it for one functionality which is working fine for slowly disappering/ appering in a slidding manner on clik of + or - sign i placed in a right top cormer of title menu bar. I wanted to give you simplified verion of my code to focus only on "Blue highlighting problem" so I skipped code realted to "doh.runner" in the attachment. The code is as follows: function wipeOut(eleId){

/*alert("eleId=" +eleId); alert("eleId=" +eleId); if(dojo.byId(eleId).style.display=="") { alert("in if ");*/

dojo.byId(eleId+'Minus').style.display="none"; dojo.byId(eleId+'Plus').style.display="";

dojo.byId(eleId).style.height = ""; var d = new doh.Deferred(); here doh.....................is used var s = dojo.fx.wipeOut({

node: eleId, duration: 500, onEnd: function(){

doh.t(dojo.style(eleId, "height") < 5); d.callback(true);

}

}).play();

return d; }

}

function wipeIn(eleId){

/*if(dojo.byId(eleId).style.display=="none") {*/ dojo.byId(eleId+'Minus').style.display="";

dojo.byId(eleId+'Plus').style.display="none";

dojo.byId(eleId).style.height = "0px"; var d = new doh.Deferred(); here doh. ....................is used dojo.fx.wipeIn({

node: eleId, duration: 500, onEnd: function(){

doh.t(dojo.style(eleId, "height") != 0); d.callback(true);

}

}).play(); return d; }

} See attachement for this "sample 1.html". In this see "Test Info 1" Table. Also see other attached html and screen shots gif files.

Waiting for your help. I am struggling on this for more than a week from my side.

Thanks.

comment:10 Changed 12 years ago by Eugene Lazutkin

Switch to the trunk --- that's where we do all modifications responding to tickets.

The best way to do it is to get with Subversion: http://dojotoolkit.org/book/dojo-book-0-9/part-4-meta-dojo/get-code-subversion. Less reliable way is to download nightlies on regular basis: http://archive.dojotoolkit.org/nightly/.

Please upgrade and recheck.

comment:11 Changed 12 years ago by Eugene Lazutkin

Resolution: worksforme
Status: reopenedclosed

No feedback was given. Closed as worksforme.

Changed 12 years ago by guest

Attachment: test1.gif added

for blue highlighting dojo version 1.0

Changed 12 years ago by guest

Attachment: test1.2.gif added

for blue highlighting dojo version 1.0

Changed 12 years ago by guest

Attachment: test2.gif added

for blue highlighting dojo version 1.0

Changed 12 years ago by guest

for blue highlighting dojo version 1.0

comment:12 Changed 12 years ago by guest

Resolution: worksforme
Status: closedreopened

I have reopend this ticket so that I can attach Screen shots and code files.

Please see test_dnd_handles_NewVersion.html, test1.gif and test2.gif files.

I have tried in a sample page provided by you people only. dojo-release-1.0.0dojo estsdnd est_dnd_handles.html and attached it as file "test_dnd_handles_NewVersion.html" to avoid similar naming convension.

My Browser is Internet Explorer 6.0 verion.

I am trying to solve this problem from my side but not yet found perfect solution.

Thanks & Regards

comment:13 Changed 12 years ago by Eugene Lazutkin

Milestone: 1.01.0.2

comment:14 Changed 12 years ago by Adam Peller

Milestone: 1.0.21.0.3

comment:15 Changed 12 years ago by dylan

Milestone: 1.0.31.3

comment:16 Changed 12 years ago by Eugene Lazutkin

Resolution: duplicate
Status: reopenedclosed

Dup of #6155, where the problem was reproduced with unmodified test file. Closing in favor of that ticket.

comment:17 Changed 11 years ago by bill

Milestone: 1.31.2
Note: See TracTickets for help on using tickets.