Opened 12 years ago

Closed 12 years ago

#4876 closed defect (fixed)

Extra tab stop at tree root

Reported by: simonjb Owned by: simonjb
Priority: high Milestone: 1.0
Component: Accessibility Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

To reproduce:

  1. open dijit/tests/test_Tree.html
  2. tab to the first tree
  3. press down arrow to get to "Asia"
  4. press shift-tab

Expected: focus to go to the object before the tree (search bar, url bar, or maybe last object in the document)

Actual: focus goes to the root node of the tree

Change History (5)

comment:1 Changed 12 years ago by Becky Gibson

Status: newassigned

comment:2 Changed 12 years ago by bill

Problem is that root node has tabIndex=0 but this.lastFocus isn't set to that node, so tabIndex never gets set to -1.

comment:3 Changed 12 years ago by Becky Gibson

Owner: changed from Becky Gibson to simonjb
Status: assignednew

seems to be related to #4773 which Simon is working on so reassigning.

comment:4 Changed 12 years ago by simonjb

Status: newassigned

comment:5 Changed 12 years ago by simonjb

Resolution: fixed
Status: assignedclosed

(In [11237]) Fixes #4773: Tree focus indication keyboard/mouse interaction problems and fixes #4876: Extra tab stop at tree root. On IE the focus outline is not shown after an alert is dismissed. This is a general IE behavior. If no alert is opened the outline is shown on IE after a click.

Note: See TracTickets for help on using tickets.