Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#4856 closed defect (fixed)

IE: button test - getting error dialogs

Reported by: ptbrunet Owned by: bill
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: Cc: brunet@…
Blocked By: Blocking:

Description (last modified by ptbrunet)

Using IE6 or IE7 go to: http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_Button.html

And get these two error dialogs:

  • Object doesn't support this property or method
  • 'dijit.MasterTooltip?' is null or not an object

You might have to press F5 (refresh) to get the second one.

Change History (6)

comment:1 Changed 12 years ago by ptbrunet

Description: modified (diff)
Summary: IE7: button test - getting error dialogsIE: button test - getting error dialogs

comment:2 Changed 12 years ago by ptbrunet

The tooltip error also happens if you hover over the Create button.

comment:3 Changed 12 years ago by bill

Owner: set to bill
Status: newassigned

OK, I will work on this. Two possible problems:

1) MasterTooltip? is created too late, after all the tooltips, so Tooltip (or ValidationTextBox?) may call dijit.MasterTooltip?.show() before MasterTooltip? is created 2) race condition on Tooltip destruction / page unload if showTimer is set

comment:4 Changed 12 years ago by ptbrunet

From irc... peteb: for http://trac.dojotoolkit.org/ticket/4856#comment:2 did you mean the problem happens on page load?

Bill, It's OK to close this. After I cleared my "temporary internet files" I can't reproduce it.

comment:5 Changed 12 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [11110]) Fixes #4856 by fixing these problems:

  1. MasterTooltip? is created too late, after all the tooltips, so Tooltip (or ValidationTextBox?) may call dijit.MasterTooltip?.show() before MasterTooltip? is created
  2. race condition on Tooltip destruction / page unload if showTimer is set

comment:6 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.