Opened 12 years ago

Closed 12 years ago

#4845 closed defect (invalid)

dijit.Tree not visible with large datasets in ItemFileReadStore

Reported by: guest Owned by:
Priority: high Milestone:
Component: Dijit Version: 0.9
Keywords: Tree ItemFileReadStore visible Cc:
Blocked By: Blocking:

Description

Dijit.tree is not visible when using large a dataset in a ItemFileReadStore?.

The tree does display with smaller dataset. That is, when there are 6 top level nodes and 860 total items in the tree is displays however, where there are 7 top level nodes and 954 items the we get nothing. This appears to be more sensitive to the number of top level nodes than total items since when I don't query for the lowest ply in the tree yet get all the top nodes I get nothing.

When treeData is specified without "identifier" and "name" all nodes appear with labels "undefined".

Attachments (1)

treeTestCase.html (17.0 KB) - added by guest 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by guest

Attachment: treeTestCase.html added

comment:1 Changed 12 years ago by guest

There are two functions in treeTestCase.html, treeTestCaseWorking() and treeTestCaseBroken(). Change the onload call to see each working (or not as the case may be).

comment:2 Changed 12 years ago by bill

Resolution: invalid
Status: newclosed

According to dojo.data there's an error in your data:

"dojo.data.ItemFileReadStore?: The json data provided by the creation arguments is malformed. Items within the list have identifier: [id]. Value collided: automotive"

Unfortunately Tree doesn't report this, so I filed bug #4860 about that.

But anyway, the root cause of the problem is invalid data.

Note: See TracTickets for help on using tickets.