Opened 12 years ago

Closed 12 years ago

#4841 closed defect (invalid)

TabContainer is not properly rendered in IE 7 if using CSS to style it

Reported by: guest Owned by: Adam Peller
Priority: high Milestone: 1.2
Component: Dijit Version: 0.9
Keywords: TabContainer CSS IE7 Cc:
Blocked By: Blocking:

Description

I've been doing some testing of the dijit TabContainer? with both FF and IE 7. FF renders it properly (as usual), whereas IE 7 doesn't. The tabcontainer overlaps its container, and anything that is supposed to be below it, it is positioned right after the uppermost part of the widget. After running the test_Tabcontainer.html, and seeing it working properly, I've realized that the test file uses the style attribute to change the appearance of the widgets, whereas I was using CSS. Also, the tabs buttons don't look as good as on FF, but that's a minor issue. I'd like to attach a screenshot somehow, but I can't do it using this interface.

Attachments (1)

tabscontainer.png (10.3 KB) - added by guest 12 years ago.
This shows the overlapping

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by guest

Attachment: tabscontainer.png added

This shows the overlapping

comment:1 Changed 12 years ago by Adam Peller

Milestone: 1.1
Owner: set to Adam Peller

comment:2 Changed 12 years ago by Adam Peller

A (simple) test case would be helpful here

comment:3 Changed 12 years ago by Douglas Hays

I could not reproduce this.

comment:4 Changed 12 years ago by Adam Peller

Milestone: 1.11.2

will take another look at this in 1.2 with the tabcontainer migration, but without a testcase and the ability to recreate, it will probably get tossed.

comment:5 Changed 12 years ago by Adam Peller

Resolution: invalid
Status: newclosed

please reopen with a test case

Note: See TracTickets for help on using tickets.